Can't upload anything to my 16MHz ATmega644p anymore?

I don't have much experience with arduino..

The problem started when I once tried to upload a sketch to my arduino using a programmer and I received an error in the console saying that the verification failed... which appeared sometimes.. but this time it wouldn't upload anything to the board. Now it says that the target didn't answer.

This is the whole error after trying to upload a sketch using the programmer

-I'm using an AVRISP MkII programmer but it only worked with the programmer set to USBasp in Arduino IDE (with the libusb or libusbK driver installed, WinUSB doesn't work)

-The board is a Sanguino ATmega644p but it only worked with Sanguino ATmega644 set in Arduino IDE

When I try to upload a sketch using the serial port, i get "target didn't answer" as well.

When i try to upload the sketch, the green LED blinks once and then the error message appears. The yellow and the red LEDs are lit all the time for me.

Any ideas?

Did your Windows update, mine just did and that has caused some problems in the past.

Have a look at the issues:

https://github.com/libusb/libusb/issues

perhaps an old device enumeration has it stuck, (just a guess).

https://github.com/libusb/libusb/issues/295