Can't upload anything to Nano 33 IoT

So this is my first time using an Arduino and I got this model as a recommendation from a professor for the project I am doing. I am running my first test on it (the whole turn on the LED on pin 13 thing from Paul McWhorter's video) and it won't upload to the Arduino. I have it set to the right board type (Arduino Nano), I have it set to the correct port, I have tried using the old bootloader, I have tried using a different USB port on my computer, I am using a data USB cable and not a charging cable, I have tried loading the .ino file directly or opening the coding software and opening the program by open > program. I have tried every solution I have found on the internet and it still will not upload anything to this Arduino. PLEASE help me!! I will past the verbose output upload below.

Arduino: 1.8.16 (Windows 10), Board: "Arduino Nano, ATmega328P (Old Bootloader)"

Sketch uses 724 bytes (2%) of program storage space. Maximum is 30720 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b57600 -D -Uflash:w:C:\Users\samsh\AppData\Local\Temp\arduino_build_746661/FirstDemo.ino.hex:i

An error occurred while uploading the sketch

avrdude: Version 6.3-20190619

     Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

     Copyright (c) 2007-2014 Joerg Wunsch

     System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

     Using Port                    : COM3

     Using Programmer              : arduino

     Overriding Baud Rate          : 57600

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

You have the wrong board type selected.

1 Like

Oh! Which board type should I be using then? Now I feel dumb lol

Nano 33 IoT?

1 Like

I am a big stupid I am sorry :') thank you. I am going to hide my shame now.

We've all done it at least one time.

1 Like