Can't UPLOAD ArduCAM ESP8266 UNO board for Arduino Camera

The upload to this board fails every time (see errors below).

I’m using Arduino 1.8.10.
The camera is the OV2640_MINI_2MP camera
The example program is ArduCAM_Mini_2MP_Plus_VideoStreaming
The comm Port is COM 7
The ArducAM board is installed
The board selected is ArduCAM ESP8266 UNO
The ArduCAM library is installed
2 different USB cables were used

Any suggestions on what I can do to correct this?

I turned on verbose for uploading and these are the abbreviated errors (the trying to connect sequence repeats many times and this was shortened to 3 occurrences)

Arduino: 1.8.10 (Windows 10), Board: "ArduCAM ESP8266 UNO, 80 MHz, 921600, 4M (3M SPIFFS)"

WARNING: library Wire claims to run on esp8266 architecture(s) and may be incompatible with your current board which runs on ArduCAM_ESP8266_UNO architecture(s).
WARNING: library SPI claims to run on esp8266 architecture(s) and may be incompatible with your current board which runs on ArduCAM_ESP8266_UNO architecture(s).
Sketch uses 231385 bytes (22%) of program storage space. Maximum is 1044464 bytes.
Global variables use 31648 bytes (38%) of dynamic memory, leaving 50272 bytes for local variables. Maximum is 81920 bytes.
C:\Users\Mike\AppData\Local\Arduino15\packages\ArduCAM_ESP8266_UNO\tools\esptool\0.4.8/esptool.exe -vv -cd nodemcu -cb 921600 -cp COM7 -ca 0x00000 -cf C:\Users\Mike\AppData\Local\Temp\arduino_build_991651/ArduCAM_Mini_2MP_Plus_VideoStreaming.ino.bin 
esptool v0.4.8 - (c) 2014 Ch. Klippel <ck@atelier-klippel.de>
An error occurred while uploading the sketch
	setting board to nodemcu
	setting baudrate from 115200 to 921600
	setting port from COM1 to COM7
	setting address from 0x00000000 to 0x00000000
	espcomm_upload_file
	espcomm_upload_mem
	SetCommState call failed
	setting serial port timeouts to 1000 ms
opening bootloader
resetting board
trying to connect
	flush start
	setting serial port timeouts to 1 ms
	setting serial port timeouts to 1000 ms
	flush complete
	espcomm_send_command: sending command header
	espcomm_send_command: sending command payload
	read 0, requested 1
trying to connect
	flush start
	setting serial port timeouts to 1 ms
	setting serial port timeouts to 1000 ms
	flush complete
	espcomm_send_command: sending command header
	espcomm_send_command: sending command payload
	read 0, requested 1
trying to connect
	flush start
	setting serial port timeouts to 1 ms
	setting serial port timeouts to 1000 ms
	flush complete
	espcomm_send_command: sending command header
	espcomm_send_command: sending command payload
	read 0, requested 1
resetting board
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
Invalid library found in C:\Users\Mike\Documents\Arduino\libraries\Arducam: no headers files (.h) found in C:\Users\Mike\Documents\Arduino\libraries\Arducam
Invalid library found in C:\Users\Mike\Documents\Arduino\libraries\Arducam: no headers files (.h) found in C:\Users\Mike\Documents\Arduino\libraries\Arducam

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I simplified this problem by using the following code instead of the example. The results of the upload are the same.

void setup()
{
  Serial.begin(115200);
  Serial.println("Hi");
}

void loop()
{
}

Sketch uses 221465 bytes (21%) of program storage space. Maximum is 1044464 bytes.
Global variables use 31352 bytes (38%) of dynamic memory, leaving 50568 bytes for local variables. Maximum is 81920 bytes.
C:\Users\Mike\AppData\Local\Arduino15\packages\ArduCAM_ESP8266_UNO\tools\esptool\0.4.8/esptool.exe -vv -cd nodemcu -cb 921600 -cp COM7 -ca 0x00000 -cf C:\Users\Mike\AppData\Local\Temp\arduino_build_413978/BirdCam.ino.bin
esptool v0.4.8 - (c) 2014 Ch. Klippel ck@atelier-klippel.de
setting board to nodemcu
setting baudrate from 115200 to 921600
setting port from COM1 to COM7
setting address from 0x00000000 to 0x00000000
espcomm_upload_file
espcomm_upload_mem
SetCommState call failed
setting serial port timeouts to 1000 ms
opening bootloader
resetting board
trying to connect
flush start
setting serial port timeouts to 1 ms
setting serial port timeouts to 1000 ms
flush complete
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
read 0, requested 1
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
Error while setting serial port parameters: 115,200 N 8 1

I bought a new ArduCAM board and this one is working okay. I guess the first one was just bad.

RESOLVED.