Can't upload code to my Arduino Duemilanove

Hello,

My Arduino Duemilanove worked perfectly for a week, but now, suddenly, I can't upload code anymore. Here is the problem:

Uploading to /dev/ttyUSB0...
>>>> /home/ori/.local/share/data/MuPuF.org/Arduino IDE/arduino-0018/hardware/tools/avrdude -q -q -C /home/ori/.local/share/data/MuPuF.org/Arduino IDE/arduino-0018/hardware/tools/avrdude.conf -patmega328p -c stk500v1 -P /dev/ttyUSB0 -b 57600 -D -Uflash:w:/tmp/arduino-buildStNdq3/sketch.hex:i
avrdude: verification error, first mismatch at byte 0x0006
0x7f != 0x8a
avrdude: verification error; content mismatch

(Linux, using ArduIDE)

  • The Arduino is not connected to anything, except for the USB to my computer.
  • It seems like the last program I uploaded is running, because the LED (pin 13) is quickly blinking twice (I think I wrote it in the setup() of my last uploaded code).
  • The '0x7f != 0x8a' line is changed if I try to upload a different sketch, but stays the same for the same sketch.

I searched a lot on the internet and this forum and found many people having this or a similiar problem, but I found no answer.

Thank you! Ori.

UPDATE: Tried on Windows with the original IDE and it still doesn't work. The same error. Is it an hardware problem? Bootloader problem?

Did you select the right board / chip type in the menu?

Yes, I tried to upload in the exact same way which always worked for me.

Ori.

Seems like it happend because I connected a motor to a digital pin... I'll buy a new ATMega and see if it fix the problem.