cant upload my code to Arduino BT ( going crazy)

I tried everything i read in this forum and other forums.

i can connec to the arduino . i chose the right board and right port #

i tried to push rest before i hit upload / after i hit upload ! i tried pushing the reset before powering the arduino BT and then release and upload

nothing work ..... please help me and tell me what to do ! :'(

any help is appreciated !!

Try to press reset when the IDE finishes verification of the code and the length is displayed in grey.

i tried all times. i still get protocol error or cant sync !

this is a poor design , is that the only way to load the code to the arduino without editing the programmer !

It is very hard to upload sketches wirelessly. I tired for a few days over xbee.

The problem is the Arduino needs to reset and start receiving code at a specific time. You can try and time it but I couldn't.

With the Xbee you can use a DIO to do a remote reset, but the bootloader doesn't leave enough time so sparkfun.com has a updated bootloader that allows more time to allow for wireless upload. It might work for BT. It is really unfortunate because for me it would make thinks much easier and I am sure for many others.