Can't upload, not responding/not in sync error.

Hi everyone,

I'm running into an issue where I can't seem to upload to my device and I can't figure out what's going wrong. I've googled and used the troubleshooting guide but so far I'm not sure what's going wrong.

I've got a (really old, which might be the problem) Seeeduino Mega with the 1280 chipset which I bought almost a decade ago and never used. I installed the latest version of Sketch, hooked it up to my computer and tried to upload a board.

The error message I'm getting is:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xce

And that repeats until attempt 10 out of 10 and then it refers me to the uploading guide:

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

In the Tools > Board menu I selected the "Adruino/Genuino Mega or Mega 2560" and the processor "ATMega1280". When looking at the COm ports I just have 1 port called "COM3" and the serial port is greyed out so I can't select it. The get board option tells me: " BN: Unknown board, VID 0403, PID 6001, SN: Upload any sketch to obtain it".

I tried updating the COM port drivers (running windows 10, with all updates/patches installed) by selecting the option to install local drivers and selecting the Arduino/Skecth install directory, but it says everything is up to date.

Bluetooth is disabled on my machine and I don't have any wifi dongles or pda sync stuff attached to my machine (as mentioned in the troubleshooting guide). I have no virusscanner installed and am just having a browser open while trying to connect to it.

Physical connection is using a USB cable straight from board to computer (no usb hub), but the troubleshooting guide says I should see a green light burning when it's connected. I don't see a green light, but when I plug the cable in I see a few red leds flashing several times. When trying to upload a sketch it also flashes the RX led from time to time, so there's at least something happening (although I'm not sure what :)).

The last part of the troubleshooting guide tells me to reset the board, but I don't really know how to do that. I also don't know if there's a bootloader on it or how I should get one on it.

Any help would be much appreciated!

edit: I tried installing the FTDI drivers and also used the Arduino Web IDE. The debug logs shows the following:

{"Version" : "1.1.60"}
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]}
{"Hostname" : "my-hostname"}
{"OS" : "windows"}
time="2017-10-07T19:00:26+02:00" level=info msg="[{COM3 0x6001 0x0403 A7004IKOA false}]"
time="2017-10-07T19:00:26+02:00" level=info msg=""
time="2017-10-07T19:00:28+02:00" level=info msg="[{COM3 0x6001 0x0403 A7004IKOA false}]"
time="2017-10-07T19:00:28+02:00" level=info msg=""
time="2017-10-07T19:00:29+02:00" level=info msg="[]"
time="2017-10-07T19:00:29+02:00" level=info msg=""
time="2017-10-07T19:00:30+02:00" level=info msg="[{COM3 0x6001 0x0403 A7004IKOA false}]"
time="2017-10-07T19:00:30+02:00" level=info msg=""
time="2017-10-07T19:00:32+02:00" level=info msg="[{COM3 0x6001 0x0403 A7004IKOA false}]"
time="2017-10-07T19:00:32+02:00" level=info msg=""
time="2017-10-07T19:00:33+02:00" level=info msg="[]"
time="2017-10-07T19:00:33+02:00" level=info msg=""
time="2017-10-07T19:00:34+02:00" level=info msg="[{COM3 0x6001 0x0403 A7004IKOA false}]"
time="2017-10-07T19:00:34+02:00" level=info msg=""
time="2017-10-07T19:00:36+02:00" level=info msg="[{COM3 0x6001 0x0403 A7004IKOA false}]"
time="2017-10-07T19:00:36+02:00" level=info msg=""
time="2017-10-07T19:00:37+02:00" level=info msg="[]"
time="2017-10-07T19:00:37+02:00" level=info msg=""
time="2017-10-07T19:00:39+02:00" level=info msg="[{COM3 0x6001 0x0403 A7004IKOA false}]"
time="2017-10-07T19:00:39+02:00" level=info msg=""
time="2017-10-07T19:00:41+02:00" level=info msg="[{COM3 0x6001 0x0403 A7004IKOA false}]"

Fixed it by switching the 3 dipswitches on the Seeeduino towards the chip as recommended by: http://www.seeedstudio.com/forum/viewtopic.php?f=24&t=518