can't upload on card


well well, I've got a prob with one off my card (usb) when i try to upload file to it the IDE write :

[VP 1] Device is not responding correctly.

what is [VP1] virtual port ?

the serial port is correct, speed correct, jumpers ok,,,,, when resetting card, it flashs one time as usual. this is not an IDE prob, it works fine with my second card.

have an idea ? how to reset in deep the card ?


Hej Eric,

I think you are experiencing a known bug in the IDE software. When exporting, instead of clicking once in the "Export" button, you have to double-click.

Is it working with this?


PS. the reason why this happens is that the software has to empty (technically called "flush") the serial port before downloading a new program. Arduino-0003 will make it properly

There is also another reason for this error.

If your code is sending data on the serial port back to the computer when the downloader is trying to send the program down to the board if receives these strange characters it cannot understant. This is what causes the message and the solution is normally to reset the board and press the download button again


it's my fault, i'm playing with the serial port therefore arduino's IDE have prob to uploading but with a double click and a reset touching, it's uploading.



Thanks for the report. I added a note about this to the FAQ:

i had the same problem after playing around with this pwd-piezo-speaker-thing.

doubleklick works fine!

thank you, hans

Also, this problem should be fixed in the next release of the Arduino software. Thanks for your patience.


I have the same problem, after playing with the pwd-piezo-speaker-thing, my arduino refuses to receive new data. I tried the doubleclick way, but then I get [VP 1] Device is not responding correctly. Programmer is not responding.

So I am not quite sure: should I reset the Arduino between the two clicks ? (I guess not and I also tried that way without luck). Is there anything I could try to solve my problem ?


reset the card and double click... it should works


ok, sorry people.

i managed to borrow another card and i get the same problem so i guess it'a a problem between my computer and me.