Can't upload on Leonardo board

Hello,

I can't upload anything on my arduino leonardo board anymore, everything was working well before i started using my ICSP pins to connect a TFT screen, using the schematics here : http://arduino.cc/en/Guide/TFTtoBoards

I'm using : win 7 , 64 bit Arduino IDE 1.5.5

I tried to upload the basic "blink" code, with everything disconnected on the board, pluged in USB, i see Arduino Leonardo ( COM5) on the device manager, start to upload, then get stuck at this stage :

Sketch uses 4,554 bytes (15%) of program storage space. Maximum is 28,672 bytes. Global variables use 151 bytes (5%) of dynamic memory, leaving 2,409 bytes for local variables. Maximum is 2,560 bytes. Forcing reset using 1200bps open/close on port COM5

A few seconds later, the IDE crash, with the following error :

Problem signature: Problem Event Name: BEX Application Name: javaw.exe Application Version: 7.0.400.43 Application Timestamp: 521c3bf4 Fault Module Name: rxtxSerial.dll Fault Module Version: 0.0.0.0 Fault Module Timestamp: 512e3235 Exception Offset: 000071fd Exception Code: c0000409 Exception Data: 00000000 OS Version: 6.1.7601.2.1.0.256.1 Locale ID: 1036 Additional Information 1: 352d Additional Information 2: 352da0ff9a3b580819eae3912b99e95b Additional Information 3: 4369 Additional Information 4: 436992e3719683e73f58f30fc672099f

Thanks for your help...

Problem solved.

I used the wrong setup code, wich messed up my bootloader, and made arduino IDE crash.

Hi , I am facing same problem. Could you kindly elaborate how did you solve this.

Thanks

I used Netbeans to fix it. You could read this : http://playground.arduino.cc/Code/Netbeans or search for Netbeans - Arduino programming. Then when you set up netbeans, open a "blink" example project, push on the reset button on the board and upload you project at the same time... then release the button. This worked for me.