Can't upload sketch, reset button not working, on my Arduino Uno?

Hello, this is my first post here. Before some time it was working fine, then I wrote a program, it did not upload because error showed as "Sketch too big". So I reduced the size somehow and then tried uploading, it showed successfully uploaded but the arduino was not working and showed this error:

avrdude: stk500_getsync(): not in sync: resp=0x00

Also i tried to reset but nothing happens when I press the reset button. The orange led (pin 13 on board) is constantly on. The led should be blinking but it's not. And while uploading a program also the led is on constantly. Before this while uploading program, the RX and TX leds went on till upload completes, but now only the RX led is blinking 2-3 times and tx led wont do anything and the led of pin 13 is constantly on , never blinks.?

I tried to burn a bootloader but it fails saying : Error burning bootloader with the same error above.

This bootloader cash issue. Use avr pocket programmer to upload boot loader

before check

1) port being detected in device manager 2) you choosen right port n board while upload code 3) Tx & Rx lines not connected with sensors.