Can't upload sketches: avrdude, usb, one specific library, computer issue?

Hi,

I've run into the situation I can't upload any sketch into any of my boards.

Arduino IDE 1.8.13 on my Mac (A1706), macOS 10.15.7 (19H114).

The problem started while I configured E32-433T20DT LoRA radios. I was using this advice and the corresponding library. I was able to read the config from radios and change it, but at some moment (last read of the config of the last radio, just to be sure; yeah I know, I'm lucky) i've got "An error occurred while uploading the sketch". Now I can't upload anything into anything. I mean, I've tried to upload the Blink to Uno and several Pro Mini's (all clones, but work fine). The error is this:

/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -cstk500v2 -Pusb -Uflash:w:/var/folders/h7/ydp62mgn5qj2rm58_jqsckyh0000gn/T/arduino_build_773416/Blink.ino.hex:i 

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/jtupulis/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : usb
         Using Programmer              : stk500v2
avrdude: usbdev_open(): did not find any USB device "usb" (0x03eb:0x2104)

avrdude done.  Thank you.

An error occurred while uploading the sketch

The problem is definitely in my computer. Blink uploads and works on the same boards from my wife's Mac.

I kind of suspect the problem initially came from the library or example sketch from the library. I've tried to remove Arduino completely including app, config and sketch folders. Restart does not help. The combination of removing Arduino, restarting, reinstalling Arduino worked once, I was able to upload Blink. After I put back the library and sketches I've made from the examples the problem was back. The method does not work anymore, I've tried several times.

I can't imagine how and what it has changed in my computer. One side effect I have noticed is that whatever it is, it is messing with I/O for the Mac. Symptoms being up and down keys are not reacting intermittently. Even after the restart. I understand that fixing my computer might take me to some Mac forums, but hoping somebody here sees a familiar situation.

I'm going crazy for the second day. Feels like a virus :smiley: Thinking of reinstalling my Mac. But then what???

I've looked for other libraries for SX1278 based radios, but haven't found anything for simply configuring them so far.

For the bigger picture, I need those radios' for RTK corrections data transmission via UART between two GNSS boards for a project I'm working on.

The output shows you're doing an "Upload Using Programmer" instead of a normal "Upload".

If you do a Sketch > Upload Using Programmer or hold the Shift key while clicking the Upload button or using the Ctrl + U keyboard shortcut, the Arduino IDE does a special type of upload that requires an ISP programmer be attached to your computer. If you don't have the right ISP programmer attached, you get this error message.

Thanks!!!

I'm using Arduino for several years for some projects. Not often, but still. This is probably the most stupid mistake I've made (and paid for it).

You're welcome. I'm glad if I was able to be of assistance. Enjoy!
Per