Can't Upload to IZOKEE Model of Pro Mini

Just got these from amazon and they seem to have a bootloader and the blink sketch works fine. I have tried everything (programming w/o FTDI, messing with the Pro Mini models, etc.) I could find on this issue and nothing seems to work.

I've also tried uploading with an UNO as ISP, changing the baud in the boards.txt file, and even burning a new bootloader (which was successful, strangely enough).

I can use a different model Pro Mini and the code works fine, but I can't seem to upload code to ANY of the 3 boards with my FTDI adapter. Would appreciate any help.

Try manually resetting the boards during the upload in case there is something wrong with the auto-reset circuit:

If you don't have an auto-reset circuit, you'll need to manually reset your Arduino during the upload. When you don't have that auto-reset, and are resetting manually, you need to get the timing right. If you press the reset button too early, the bootloader will have already timed out by the time the upload starts. The tricky thing is that when you press the "Upload" button in the Arduino IDE, it first compiles your sketch before starting the actual upload. So you need to wait until after the compilation finishes before pressing the reset button. The way to get the timing right is to watch the black console window at the bottom of the Arduino IDE window. As soon as you see something like this:

Sketch uses 444 bytes (1%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

press and release the reset button. The upload should now finish successfully.

nickalith:
I've also tried uploading with an UNO as ISP

Note that when you do that you erase the bootloader. This means that after doing an "Upload Using Programmer", you need to do a Tools > Burn Bootloader before you can go back to uploading via the FTDI again.

nickalith:
changing the baud in the boards.txt

You are going to compound your issue if you're not careful. Please do this:

  • Revert the baud rate values you changed back to the original values.
  • Restart the Arduino IDE so the change to boards.txt will take effect.
  • Connect your Arduino as ISP to the Pro Mini.
  • Tools > Board > Arduino Pro or Pro Mini
  • Tools > Processor > ATmega328P (3.3V, 8MHZ)
  • Tools > Burn Bootloader
  • Wait for the process to finish successfully.

Now try to upload with your FTDI.