Can't upload to Mega 2560

Hello,

My mega 2560 worked fine before, I was able to upload the code successfully but suddenly when I try to upload it is giving me following error message.

avrdude: stk500_2_ReceiveMessage(): timeout

I have tried re-installing the software and the driver and it is still not helping. Also, in the tools menu, in serial port, I don't see USB modem choice. The TX and RX leds are no longer even turning on when I click upload.

Could anyone please point me in right direction?

OS: Mac os x 10.7.2

Could there be something wrong with the bootloader chip?

I reinstalled the Arduino software. According to the "getting started" page:

"If you're using the Arduino Uno or Arduino Mega 2560, a dialog box will appear telling you that a new network interface has been detected. Click "Network Preferences...", and when it opens, simply click "Apply". The Uno or Mega 2560 will show up as "Not Configured", but it's working properly. Quit System Preferences."

No dialog box appeared when I connected the mega 2560. It's not there in network preferences.

Come on guys, no one??

the usb ports might need a full power off reset.

  • shut down the machine, disconnect the power cord
  • if the system is a notebook disconnect the battery
  • disconnect all usb cables from the computer
  • wait 30 seconds
  • put the battery back in if applicable
  • plug in the power cord
  • boot up
  • reconnect usb cables
  • try uploading now

hope this helps!