Cant upload to Micro

Over the last few months I have been working with various Arduinos writing the occasional program and had good success.
I have about 8 different Arduinos, Uno's, Megga's, Micro's etc. I now find I can upload programs to the micros !!! if for example I load the Blink example it compiles fine it starts to upload then just sits there. The program that was originally on the micro is still there and still works perfectly. thus ruling out a defective micro. I have re-installed Arduino software, iv tried 2 different leads and tried different usb ports on computer, still no upload.
I get no error messages.
I've double checked every time the Board setting and com port are correct
If I swap the Micro for a uno and alter the board type it compiles and loads perfectly.

Any ideas welcome

This is report I get When I set show verbose output on uploading.


Sketch uses 4,594 bytes (16%) of program storage space. Maximum is 28,672 bytes.
Global variables use 149 bytes (5%) of dynamic memory, leaving 2,411 bytes for local variables. Maximum is 2,560 bytes.
Forcing reset using 1200bps open/close on port COM6
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
Uploading using selected port: COM6
C:\Program Files\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega32u4 -cavr109 -PCOM6 -b57600 -D -Uflash:w:C:\Users\Lynton\AppData\Local\Temp\build08e4957f02c018eb579e11ddc64f9701.tmp/Blink.ino.hex:i

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM6
Using Programmer : avr109
Overriding Baud Rate : 57600
AVR Part : ATmega32U4
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PA0
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 20 4 0 no 1024 4 0 9000 9000 0x00 0x00
flash 65 6 128 0 yes 32768 128 256 4500 4500 0x00 0x00
lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : butterfly
Description : Atmel AppNote AVR109 Boot Loader

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding


Try tapping the reset button on the Micro when it starts searching for the port. It is searching for the port when it displays:

PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
PORTS {COM1, COM6, } / {COM1, COM6, } => {}
...