can't upload to my Arduino Duemillanove

Hi I get this message when trying to upload to my brand-new just out of the box Arduino Duemillanove. I have used two other Arduino Duemillanoves before on this same computer with no problem. I have selected the correct serial device under tools. I have tried everything on the troubleshooting page at arduino.cc. I'm not an Arduino noob but I don't know why I can't upload (Firmata) to this brand new Arduino. I am on a MacBook Pro running Mac OS X 10.5.4.

Can someone please give me some good answers to fix this problem? Note that I have already tried the troubleshooting tips.

I have EXACTLY the same problem as you, running the same OS...

Is your new board supplied with the 328 chip. If so in the tools/board selection you need to pick the entry that has the 328 chip in it’s name.

Lefty

I had the exact same problem. I took the RXTXcomm.jar file from my JAVA extensions library folder and put it in a temp folder. As soon as I did that I was in business.

My system - Duemillanove with a 328 chip running on a 2x2.66ghz Dual xeon Intel running 10.5.6 os

engine