Can't Upload to My Second LilyPad :-(

Well… I’m back!

I never got my first LilyPad working - for now I guess I’m just assuming it’s defective.

I received my second one this morning, however, and now am having a COMPLETELY DIFFERENT problem!

Everything seems to be going fine during the upload up until I get this message:

avrdude: verifying …
avrdude: verification error, first mismatch at byte 0x0000
0x0c != 0xff
avrdude: verification error; content mismatch

And, unfortunately, the blink sketch doesn’t get loaded. (The boot loader just seems to continue along.)
What on earth could be causing this one? Does this mean there’s something up with a fuse setting and the data isn’t being written? Would it be something I can fix with only my FT232RL Arduino Serial USB Board or with the LilyPad USB Link?

The command I tried was:
avrdude -Cavrdude.conf -v -v -v -v -pm168 -cstk500v1 -P/dev/ttyUSB0 -b19200 -D -Uflash:w:/tmp/Blink.hex:i

Here’s a link to the full output of my upload attempt:
http://sleepphones.dyndns.dk:1977/upload_attempt.txt

Has anyone got any ideas? Is it time to send these two back and try for a third? I sure hope I’m missing something really stupid this time…

Thanks for any help!
Jason

have you also tried uploading directly from the Arduino software?

I'm honestly stumped. If you want to send me your LilyPads I can do some in person troubleshooting & send them back to you. Email me if you want to do that: buechley@colorado.edu.

Thank you so much! I MUST be doing something wrong. I'll send you an email.

It seems like a small batch of LilyPad with corrupted bootloaders was sent out. This happened to some LilyPads that were sent out in the last month or so. We have restructured our testing process to make sure this does not happen again! If you think you have one of these bad LilyPads, get in touch with sparkfun about a replacement.

My sincerest apologies for this.

Leah