Cant upload to my two Uno's via USB only ICSP

Hi!

I have a problem with uploading to both my Uno’s, one clone and one not a clone. I get the < stk500_getsync(): not in sync> error when I try to upload using the USB cable. I have tried on two different pc’s, and with several different usb cables. I can upload sketches to a couple of Nano’s so I still have a working ide (I also reinstalled to the newest ide). I also tried to change the atmega328 to a new one.

To check if the Uno’s was totally destroyed I tried to upload a sketch from a Nano to the Uno using the ICSP pins, and that worked!

How can it be that both Uno’s have the same fault? Could it be one of my shields that has crashed them? I have mostly used them as a programmer for barebones, I prefer to make custom circuitry if I can so my uno, nano and micro is free to prototyping.

But I still want to have my Uno’s working from the usb. Is it possible to reset or reinstall the usb port/circuitry? Is it still hope for my Uno’s? I just cant afford to buy two new Uno’s now, and I need them both for a project!

Please help!!

The RX led flashes tree times and then turns off.

Loopback test is OK!

Verbose during upload :
C:\Program Files (x86)\Arduino\hardware/tools/avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega8 -carduino -P\.\COM3 -b115200 -D -Uflash:w:C:\Users\Kjell\AppData\Local\Temp\build3433385074847402489.tmp\Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you.

(deleted)

I know that the error say that I have chosed the wrong board. But, that was the first thing I tested, so basic that I didn't write it up in the list of things I have done.

My thought is that the atmega 8u2 (or 16u2) if faulty. So I'll try to flash it tomorrow.