Can't upload to Nano. Port greyed out.

When I try to upload a sketch to my Nano board I get the following message (the sketch loads and runs if I upload to my UNO board). Both boards are from Arduino.

Arduino: 1.8.13 (Windows 10), Board: "Arduino Nano, ATmega328P"
Sketch uses 4068 bytes (13%) of program storage space. Maximum is 30720 bytes.
Global variables use 242 bytes (11%) of dynamic memory, leaving 1806 bytes for local variables. Maximum is 2048 bytes.

An error occurred while uploading the sketch

avrdude: ser_open(): can't open device "\.\COM3": The system cannot find the file specified.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

The IDE shows a connection to Nano on COM 3 in the lower right hand corner, but in Tools, the Port selection is greyed out. If I go to Board Manager it shows Arduino AVR Board version 1.8.3 installed but won't give me the option to update (running Arduino version 1.8.13). My device manager says the drivers are not installed for FT232R USB UART, but can't locate them to install them (running Windows 10). I've gone to the FTDI website but can't find the necessary drivers there either. I'm no expert so haven't been able to go further. Any help available?

(deleted)

What does your operating system think about the Nano? In Windows, it would be in device manager.

If your OS does not detect it (and other ports), the port section in the IDE will be grayed out.

I have uninstalled and installed the Nano board 3 times (Windows 10). I get the notification that it is set up and ready for use, but if I go to Device Manager it says FTB232R USB UART is installed in Other Devices, but tells me no drivers exist. When I try to install the drivers Windows cannot find them. Further, when I plug it in it does not activate Ports in the Device Manager tree. However, the green light on the Nano comes on. I’m using a UGreen mini usb cable.

I always battle a bit when installing drivers (never know which directory I exactly need to select).

The drivers for the FTDI should have been installed when you installed the IDE; I have a SparkFun RedBoard the used the FTDI and I can't remember that I ever had to install the driver manually.

But the drivers should be in C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers; so try to select that directory when installing the driver.

I followed your advice but Windows said it couldn't update due to a corrupt or missing file. So I uninstalled and re-installed the IDE from the Arduino website. Same thing. The FTDI USB Drivers folder is where it should be, and when I plug in my UNO board everything works as it should. Any other thoughts? It seems like I'm not the only one having this problem. Could it be a bad NANO board or cable?

I think that I'm out of options.

Last comment is that if the FTDI disappears from the device manager when you disconnect it, your cable is OK.

Thanks for trying. And yes, I agree the cable is working. I'm waiting for more input from the Arduino tech people and if something ends up working I'll post it here.

(deleted)

@esmith1971

Could you also take a few moments to Learn How To Use The Forum.

Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

I found this thread because I was also having a problem with my Nano being found by my Windows 10 system. In my case the issue was caused by my Nano having a different chip than the FTDI. Apparently some sellers are producing Nanos with the CH340 chip instead. I was able to download and install the driver from here:

and this solved my issue.
I also want to give credit to Maggie Shah on Instructables for guiding me to this cause: Arduino Nano USB Not Recognizing (Fix). : 8 Steps (with Pictures) - Instructables

See attached (I can't seem to embed a snapshot of my Nano's chip)

  • Vince

ch340 chip instead of ftdi.jpg

ch340 chip instead of ftdi.jpg

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.