Can't upload to pro mini, help me troubleshooting!

Hey Boys,

I have purchased a clone of pro mini, from here: http://www.watterott.com/de/Wattuino-pro-mini-5V-16MHz I also use the SF FTDI Breakout V1.1, which should work fine with it. However, I have not been able to upload anything to the board. I am using Win7x64, and a USB cable of which I am sure that it is working. I also have selected the right COM port. I tried uploading using different settings in the Boards-menu. (i.e. duemilanove) I tried different baudrates, which I changed over the boards.txt file. I have pushed the reset-button before and while uploading, neither worked. I did the serial-communication-test, seems good. Nothing works, I always get the same error: avrdude: stk500_getsync(): not in sync: resp=0x00

I have uploaded a short video of what happens when I try to upload. First, I plug in the USB-cable and the board and breakout do some blinking. I then click on upload (this is where I move in the video) and the board seems to get resetted successfully, then the breakout RX and TX diodes blink, then nothing.

http://www.youtube.com/embed/S8bwSih4Z-c

What is wrong with that thing??

Have you tried selecting UNO in the Boards menu?

The website, you linked to, said it is using: "Bootloader: Arduino Uno Optiboot"

(deleted)

Uploading as uno doesn't work either :(

This is the breakout:

http://www.watterott.com/de/FTDI-Breakout-Reloaded-V11

(deleted)

Okay, well. Hardware seems to be fine. I just tried another computer, it worked! I will try to refresh my arduino ide…

(deleted)

Yeah, well.. It doesn't work fully yet! What can be the reasons for it not working on my main machine? I redownloaded the arduino program and replaced it, alongside with the preferences.txt file. Not working, same error. Why is that? :(

(deleted)

directly or hub, both don't work.

(deleted)

What OS are you using.In MS windows you had to manuel install driver for USB.

I am running Win7x64. I thougt about drivers too, but I shouldn't need those, I guess. As I am using a Breakout, all the communication works over Serial communication, doesn't it?

Sorry for begging, but does anyone have any idea, what the cause for my problem might be?
I really don’t get it…