Can't upload to Uno R3 Atmega328P, fails loopback test


So I tried the loopback test outlined here and the Rx light blinks when I transmit something but the Tx light does not (and no response is transmitted back to my terminal). I am unable to upload any of the default sketches to it (avrdude: stk500_getsync(): not in sync: resp=0x00)). Reinstalled drivers, even dualbooted lubuntu and tried it with various different versions of the Arduino IDE; no dice. I've tried the magical "holding the reset button at different times" thing as well.

Interesting thing is I tested it on my friend's laptop with the same results, and we tested his Duemilanove on both computers with the same error. (I believe we were using the same cable for both tests, so that might be the issue but it's getting power and receive data so I feel that it's unlikely).


Edit: Here's the log output of an attempted BareMinimum upload:

Sounds like you either have a bad cable, or you zapped the board somehow.

Aw, bummer. Well, been meaning to order a new one anyways. Thanks!