Can't Upload

I have a Duemilanove, I'm on Windows 7, I disconnected everything from the board, and have tried the troubleshooting guide. When I press and release the reset button I get one blink. The power led is on. When I hit upload the RX led starts to blink, the TX however does not. There is nothing metallic touching the Arduino, except for three screws that are screwed through the three holes in the board (I took the board off and tested it, I get the same errors). I have checked every component on the board to make sure there wasn't any metal bits, nicks, or cuts in it. This was a preassembled board.

I was messing with an IR sensor. I uploaded the program to the Arduino and it uploaded fine. I noticed that I was using pin 13 instead of pin 12 like I thought, so I changed that in the program. This time however I got the following errors:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

This is the code I am using:

void setup()

void loop()

This isn't a driver or firewall issue, the board was working 5 minutes ago, I can't upload to it now for some reason...

my first tip for anyone using winblows:

have you rebooted your machine already ?

could wiring the sensor to the wrong pin in any way have caused a short ? what does your schematic look like ?

you said you had already consulted the troubleshooting FAQ, so did the loopback test verify that the usb/serial chip still works ?

Yes I have, it's not a Windows problem. I just got done trying it on linux, and I get the same errors. I am making a small obstacle avoiding robot, and the Arduino board is mounted on a piece of plastic a few inches away from two motors. Could I have ruined the board with the magnetic interference? If so can I just burn a bootloader back onto the the atmega328p or would I have to buy another one? Or could I have ruined the whole board?

well, do the loopback test and you will know if the usb chip is still good. replacing the atmega chip is easy, just like burning a new bootloader (with the right tools of course).

I'm not quite sure how to do the loopback test. I came across someone saying to do that when I was looking at similar error situations. Here's the topic. The post said:

Did you already do the RX/TX pin loopback test ?

Take a wire and connect RESET to GND to disable the microcontroller. Then take another wire and short pin-0 and pin-1.

Use the serial monitor and input some text. If you press SEND, it should be echoed back. If that works, it may be a bootloader problem or a dead chip.

You can try changing the upload speed of the IDE for your board. It's either 19200 or 57600. Changes need to be made in boards.txt + restart of the software.

What does he mean by short pin 0 and 1???

EDIT: I just noticed you were the one who posted that... :P

well, you take a piece of wire and connect the duemilanove's RX and TX pins directly with each other ( shorting them ). before that take another piece of wire and "short" the RESET to GND. this way the atmega plays "dead dog" and all of its pins should be turned to inputs.

so everything that gets sent to the board from your pc is immediately sent back. so if you take a terminal program (e.g. the dreadful hyperterm if you're on a windows xp machine) and open the serial port to which the arduino is connected, everything you type into your keyboard should be sent back to you. this will manifest itself by you being able to read what you typed, as it should show up on your screen. if you happen to have "local echo" enabled, you'll see everything typed TWICE if the board is ok.

if this test passes, the problem only lies within the atmega chip. first try reflashing the bootloader if you have the tools to do that. if that doesn't help, get a new ATmega chip and make croûtons of the old one. feed to your enemies.

Do I have to enable local echo or is it enabled by default? Because when I send signals the Arduino receives them (RX blinks) but it doesn't send them back (TX doesn't blink)...So if it isn't sending signals does that mean that the FTDI chip is gone?

You don't have to enable local echo. I just wanted to mention it, because IF you had it enabled unknowingly, you might have been tricked by it and get a false test result. So make sure you know that it is off.

To make sure the usb chip is not confused by a broken ATmega chip, you can remove the 28pin chip with a small screwdriver by gently inserting it from the sides (where no pins are) and wiggling it up/down on both sides until the chip pops out (without bending the pins). These results would be more reliable.

Then the results are unequivocal. If you see text coming back on your screen the usb chip is ok (and the rx/tx leds blink). If you don't it's gone. The chip can be replaced if you're quite skilled with a soldering iron (or better hot air thingy) and costs about 4$ for a single one. Maybe you have some sort of Hacker Space in your neighborhood, they will have the right kind of people to do that.

I also have an error of:

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

When I press the reset button, the LED won't blink, but we tested the LED and it works (pin 13) no boot loader? . The power indicator LED works fine.

My board is:

Freeduino Serial v2.0 board KIT Arduino Duemilanove Compatible ATmega328P microcontroller and requires Arduino IDE version 0013

External power source: 9vdc 500ma

I got the capacitors mixed up at first and soldered them in the wrong positions; did that damage the ATmega328P IC?


:o Same thing just happened to me but the first test program I put on is working fine.

The array tutorial is currently playing on my arduino just fine.

but i cant re program it to do anything else and it gives me the same error message.

Binary sketch size: 896 bytes (of a 30720 byte maximum)

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I was connecting my led cube while it still had this code on it and the cube was actually running without being connected to ground idk why this is but maybe that's what caused the problem?

EDIT: I conducted the test my text is coming back just fine with or without the atmega 328 i did not notice my leds blinking, is this bad?

at this point i think it's a driver issue becase even on a computer with out the driver installed it gives the same message i think something happened to my driver when i was messing with a library.

Yes, drivers… possible :wink: and the RX/TX LEDs really should blink while you’re typing. If not, the text is echo-ed locally. Which doesn’t tell us much.

And Windows XP SP3 is the one OS by micro$soft I hate the least… Vista is an abomination for sure. I haven’t tested W7 yet and unless I get it for free I never will.