Can't upload

Hi I am having similar difficulties with my Uno. It was working OK until I decided to use an external power supply. The guide suggests anything up to 12V is all right. I connected via a shield to the Vin pin. Everything seemed to be working OK for a while and then it all stopped - power light went out. Close inspection of the Uno schematics shows that the Vin pin is downstream of the 1N4007 diode that prevents reverse polarity mistakes. The diode also introduces a 0.7V (approx) drop. Found this out after I hooked up a 9V supply via the power in socket. Other responses suggest that an overvoltage power supply seems to cause problems. Since then I have tried the following. 1 Replace the ATMega328 chip - the new one must come with "Blink" preloaded because it blinks at me when powered up - but try to upload a new sketch and I get the familiar: avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51 This seems to be a timeout response because it takes some time to appear - much longer than a normal upload.

2 Put the old chip back on board - and tried the "Loop Test" - it worked perfectly so serial communication via the USB is OK Without knowing what it could be - it seems that the board has been damaged and so prevents uploading from completing its course. Not sure what to do next except buy another one.

When powered from a USB port, does anything get hot?

It looks like the auto reset doesn't work anymore. Try to reset manual at the moment you push the upload button hold the reset button. and let it go if the IDE is done with compiling and starts to upload the sketch.

You can test if the reset is the problem: Let the blink test run and upload A sketch, the blink should stop for A little while at the reset of the microcontroller.

My new Arduino's arrived in the mail and so I have been using them - no time to play around with fixes, but thanks for the tip. I will try a manual reset while uploading.