CardInfo Shows Disk is Not Formatted, when it is?

Hello everybody, I’m new to using SD cards with arduinos. Admittedly I bought some cheap ones off amazon: https://www.amazon.com/Cloudisk-Capacity-Special-Storage-Advertising/dp/B083NQHPSG/ref=cm_cr_arp_d_product_top?ie=UTF8 I’m using an Arduino Nano.

They are 512Mb SD2 cards. I’ve tried both FAT and FAT32 formats for the cards, and they do not work for the card. I figured for my uses for arduino I’d never need more than that for storage space.

The CardInfo example in the arduino IDE is giving me this:
"
12:57:53.189 → Initializing SD card…Wiring is correct and a card is present.
12:57:53.256 →
12:57:53.256 → Card type: SD2
12:57:53.256 → Could not find FAT16/FAT32 partition.
12:57:53.322 → Make sure you’ve formatted the card
"

I’m aware it isn’t the card reader, because I also have a 8gb SD card I swiped from a raspberry pi that the reader reads just fine. Curious why these cheapo ones might be giving me issues? They work just fine when plugged into an USB to SD converter on my PC for storing files.

edit: I also had attempted to use the SD card formatter pinned within the Storage thread. Yielded the same result for the card, both with quick and overwrite format.

edit2: Figure I should also include the SD card scanners I’m using: https://www.amazon.com/gp/product/B08CMLG4D6/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

Did you read the sticky at the top of the forum with guidelines for formatting cards?

Yes I had, apologies I hadn’t included that in my post. Using Tuxcera’s SD Card Formatter yielded no change. Not recognizing the SD Card’s Formatting. Will edit main post, also included the SD card reader I’m using.