Catalex MicroSD Card Reader Issues

Hello,

I am attempting to use a Catalex MicroSD Card Adapter (V1.0 09/02/20133), and am having issues with SD card initialization. I have tried different microSD cards, reformatted, and different Catalex adapters (same version).

I have also tried the solutions found in this thread, including jumping the appropriate wire.

Any ideas on what is wrong/how I can resolve the issue? Pin layout is correct.

Using a generic brand nano.

Thank you!

chipSelect = 10

void setup ()
   pinMode(chipSelect, OUTPUT);

some example programs do not do that pinMode... and they work. in my experience, it cost nothing, hurts nothing, and the SD card works if you use it.

I believe I found the issue, although I'm not sure what to make of it...

Using an Arduino Uno, I am able to communicate with and execute tasks on the MicroSD Adapter. However, the adapter does not work on the Nano.

Any ideas on what the cause of this discrepancy is?

maybe something here can help:

why an uno works when a micro does not

different platform with physical similarities

I found the solution for this probem.

The MISO pin (7) of card need a pul-up resistor (10k~100k) when there is no pull-up in the microcontroller.
However, in this case, the Catalex has a buffer between microSd Card socket and the microcontroller pin.
The solution is put the pull-up close to the socket.

See the picture with the solution that I made.

lepoloni could you please attach the picture/photo for catalex mod that you have inserted (image is not clear)...
I hope this will help in my SPI multiple connections.....!!

beetlenut:
lepoloni could you please attach the picture/photo for catalex mod that you have inserted (image is not clear)...
I hope this will help in my SPI multiple connections.....!!

READ ---> I cannot find the datasheet for Catalex MicroSD Card Adapter - Storage - Arduino Forum