CC3000 with Arduino Uno R3 Couldn't get a wifi connection. Please help!

Hi everyone. I'm extremely new to this, but it doesn't seem like rocket science. At least, not the minimal stuff I'm doing at the moment.

I've got an Arduino Uno R3 paired together with a CC3000 wifi shield. Both purchased from Adafruit.

If I run buildtest, I can successfully scan, connect, and disconnect from a WPA2 network.

However, when I run anything else, my own code &/or examples, it fails.

I get the following message...

Attempting to connect to WPA network... Couldn't get a wifi connection

It strikes me as odd because it works great when I'm doing buildtest, but other than that...fail

Soldering is fine, pins are fine...in case that was the first question. Also, I've tried IDE 1.0.5, 1.0.3, 1.0.2, etc etc. All to no avail.

I've also tried both usb with serial port, and then I've tried plugging it into power watching my router hoping it would connect :(

I've got green lights on both uno & shield, so I really don't know what else to do.

Please advise :(

All the best!