CH340/CH341 Drivers Fail in Lubuntu (Ubuntu 18.10)

Good day all,

I recently installed Lubuntu (based on Ubuntu 18.10) Arduino IDE 1.8.10 on an old Acer netbook I had lying around. With little else running on it, I thought it would make a nice Everyday Carry for light duty arduino development.

The first little project worked just fine using an Adafruit Huzzah esp8266 and an Adafruit FTDI Friend (No USB on the Huzzah).

I then moved on to another little project that I wanted to put on a Wemos D1 R1. There was no available serial port and efforts to open the serial monitor resulted in an error message.

I messed about with some other ardunio flavors I had:

Wemos clone = fail Uno = success Uno clone = fail

A couple days of googling and a whole lot of lsusb and dmesg suggested that, even though I'm running a linux kernel, the likely problem is that the clones are using CH340/CH341 chips and my system wasn't recognizing them -- even though linux nominally has drivers as part of the kernel. I went looking for a likely driver and found ti_usb_3410_5052.ko lurking down in /lib/modules/4.18.0-25-generic/kernel/drivers/usb/serial

insmod ti_usb_3410_5052.ko fails with insmod: ERROR: could not load module ti_usb_3410_5052.ko: No such file or directory

sudo modprobe ti_usb_3410_5052.ko fails with modprobe: FATAL: Module ti_usb_3410_5052.ko not found in directory /lib/modules/4.18.0-25-generic

I tried downloading "patched" drivers from WCH but the make failed with error messages I couldn't interpret and I don't know enough to try editing the makefile.

So the questions are:

  • Is my problem really with the CH340/341 drivers or is that a red herring?
  • If so, is there a fix that doesn't involve compiling my own drivers?

Thanks in advance for any and all advice.

Unless it has been changed the linux driver is named ch341.ko. Nothing from dmesg and lsusb? Try a different usb cable. Lots of dud cables out there. Try running the IDE sudo, maybe a permissions problem. If you get errors post them, somebody may recognize the problem.

I use Ubuntu 18.04 with many different boards and have never installed a CH34x or CP210x driver. The included drivers work for me. Bad USB cables are very common.

Also, ti_usb_3410 has nothing to do with the ch340. That’s TI’s old usb/serial chip. (Iirc, it normally needed code uploaded to it before it would work, so it needed special drivers.)

Thanks to all for your replies.

I'm embarrassed but grateful to say yup, it was the cables. I now have a known-good cable marked and set aside.