Ch340 nano on MacOS Catalina

My lafvin nano clone is showing up as dev/tty.usbserial.xxxx and dev/cu.usbserial.xxxx. Xxxx depends on the USB port I use so I know the Mac sees the board. No issues with a uno clone but that might not use a ch340.

I get the port coming up in the ide but can’t pull the board info. Native serial port can’t obtain info

I have set the ide to old boot loader and not. Tried using uno as the board. Rebooting. And anything else that seemed to make sense.

Mac OS Catalina 10.15.??

Get board info only works on boards with the 16u2. It will always say it can't get info because it's a native serial port on boards with a CH340G or CP210x serial adapter.

Ignore "get board info" - it doesn't really mean anything (if it were up to me, I would remove that menu option - it's just a red herring, and I have gone in circles with another poster over this, because he was dead set on the idea that the fact that it returned nothing was indicative of a problem, and couldn't be talked out of this belief, or into telling us what happened when he tried to upload to it)

As for why it returns something with the other clone, examine the chip next to the USB port. My guess is it's a 16u2 like the official boards use (what I refer to as a "faithful clone")

What matters is whether you can upload to the board. Can you? If not, what's the error? If you can, then there's no problem, proceed with project.