CH34x dosn't work on Mac OS High Sierra (10.13.1)

Hi, I bought some esp01 and nodeMCU that works with CH340G, my mac did not detect them so I've installed many times the last version of the driver (v1.4), version not easy to find.. I read many tutorial and watched many videos, but every solution doesn't work for me..

The position of driver: /Library/Extensions/usbserial.kext

Today, I tried to open usbserial.kext to /Library/Extensions/usbserial.kext/Contents/MacOS/usbserial

The last usbserial is a exec file so I started and this was the response on terminal:

Last login: Fri Dec 15 18:34:39 on ttys000
JARVISMk7:~ Manfredi$ /Library/Extensions/usbserial.kext/Contents/MacOS/usbserial ; exit;
-bash: /Library/Extensions/usbserial.kext/Contents/MacOS/usbserial: cannot execute binary file
Saving session...
...copying shared history...
...saving history...truncating history files...

[Processo completato]

So I'm not very good in this field of application, but I think that for some reason it's impossible to open the file, it's correct? Anyhow, someone has had my self problem? How can I solve the problem?

P.S. I'm italian, so if i'm not clear tell me and I'll explain better I've already asked in the italian forum but I don't find a solution, maybe here I'll be luckier. :grinning:

For what its worth, I have the same problem, and it is not just NodeMCUs. When I ran into this, I tried switching back to an older project from a month or so ago that used DigiSparks and I can no longer communicate with that either. I suspect it is something in very recent OSX updates.