Changing Baud Rate on SparkFun Bluetooth Mate Gold

Hi,

I'm following this setup in the link below to get my Razor IMU to operate wirelessly. https://github.com/ptrbrtz/razor-9dof-ahrs/wiki/Tutorial

After uploading the program in the link above into the Razor IMU (note that in the program, the baudrate is set at 57600), I hook it to the Bluetooth Mate Gold.

Since the default baud rate of the Bluetooth Mate Gold is 115200, so it made sense that the serial monitor doesnt display the Yaw, Pitch and Roll if the baud rate is not set to 57600.

Then, I attempted to change the baudrate of the Bluetooth Mate Gold from 115200 (default) to 57600 to match the baud rate of the Razor IMU by using this tutorial: https://learn.sparkfun.com/tutorials/using-the-bluesmirf/introduction?_ga=1.146389943.2039360575.1431500479

But, instead of hooking the bluetooth module to Arduino as shown in the link above, I changed the baud rate while the Bluetooth Mate Gold was connected to the Razor IMU and the batteries.

Once it was done, I opened the serial monitor and regardless of the baud rate setting I chose, it displayed all readings legibly.

My question is why does this happen? At what baud rate is my system running at now? Will this in any way have negative effects on my system.

Thanks.