Charge inductive et parasites

slt pour ma part une diode à suffit à enlever le parasitage

Tu parles de quoi ? de diode de roue libre ? Car je vois mal où placer une diode au niveau des contacts du relais ou de la charge ...

Ba une diode toute simple entre le + et - de la bobine du solenoid

Ca evite le retour de jus.

Moi ça me faisait bugger l alimentation et redémarrer l arduino

Et selon la taille de la bobine ça me faisait bugger l ecran comme toi voir ça me killait le programme et m obligait a restarter

Sur ce montage, j avais oublié la diode

La diode de roue libre protège surtout le transistor de commande. Elle est fortement conseillée, je dirais même obligatoire. Cela n'a rien à voir avec ce sujet, où l'on parle de surtensions et de parasites provoqués par la commutation d'une charge inductive sur le secteur.

ba moi je te dis que ce phenomene de parasitage d'ecran se resoud dans mon cas avec une diode, c'est tout, c etait juste pour apporter ma contribution

bonne journée

Le propos ici c’est de supprimer les parasites venant du circuit en 230VAC et non ceux de la bobine du relais côté courant continu, donc pas de + et de -.

Mettre une diode en parallèle des contacts du relais va permettre le passage d’une demie alternance dans la charge: il n’y aura donc pas coupure. C’est ce que t’explique Henri dans son message précédent.

De plus si tu regardes bien son schéma, la diode de « roue libre » est bien présente en parallèle du « solénoïde »/bobine du relais Cette dernière ne résoudra pas tout

Sur ce montage, j avais oublié la diode

On ne le répétera jamais assez : cette diode est indispensable.

Quelques explications à propos de la diode de roue libre ici (avec oscillogrammes) : alimenter-un-relais-transistor

Voir 1.1. La diode de roue libre

Surtension sur le collecteur du transistor (100V)

Perturbations au niveau alimentation (+/- 15V)

Suffisamment éloquent non ?

Je n'ai pas fait de relevés sur ce qui se passe lors de la commutation d'une charge inductive sur le 230V. Mais j'ai déjà eu des problèmes de plantage d'écran LCD (voir #1), et un condensateur + résistance ou une varistance en parallèle sur la charge permet de résoudre le problème.

J'ai rencontré un nouveau problème de parasite sur ce projet : carillon MP3

Un relais 12V (avec diode de roue libre 1N4148) est utilisé pour mettre sous tension une alimentation à découpage MeanWell 24V 50W, une LRS-50-24.

Aléatoirement, lors de la commutation du relais, l'ARDUINO PRO MINI redémarre.

Si l'alimentation de 50W est sous tension en permanence, aucun problème. Le relais est toujours commandé, ce qui le met hors de cause.

En essayant d'appliquer la recette condensateur + résistance en parallèle sur l'entrée 230V de l'alimentation 50W, cela ne donne aucun résultat. La vérité est ailleurs apparemment.

J'ai essayé par pur hasard de débrancher le convertisseur USB / série de la PRO MINI. C'est un FTDI FT-232R-3.3V :

Le problème disparaît. Ça se corse ... Il y a probablement un parasite sur le fil RTS câblé sur le RESET de l'ARDUINO.

Je remplace le convertisseur par un modèle chinois (FT232R) :

Le convertisseur est branché au PC avec un câble USB blindé de 25cm et à la PRO MINI avec des fils GND, RX, TX et DTR très courts : 5cm. Le problème ne réapparaît pas. Tiens donc ...

Je reprend le FTDI FT-232R-3.3V et je raccourcis le câble de 1.80m à 30cm. Le problème ne réapparaît pas non plus.

L'origine des parasites se cache parfois dans des endroits où on ne les attend pas :confused:

Bonjour,
Je voudrais revenir sur le schéma donné au 1er post, la protection, que ce soit RC ou varistor, doit-elle être câblée en parallèle de la charge ou en parallèle du contact du relais?

Merci de m’enlever ce doute.

En parallèle sur la charge.

C’est bien ce que je pensais.
Merci pour ta réponse.

Bonjour Henri,

Comment règles tu ton oscillo pour capturer ce genre d’événement unique?

Bonjour

Au vu de la copie d’écran en haut à droite, (zone T pour threshold) je dirai : probablement Synchro sur front montant du signal appliqué en voie 1, avec un seuil de +2V

Vu la surtension le seuil aurait pu également être positionné plus haut

synchro.png

|500x500

Régler le petit bouton "Level" à droite pour positionner le curseur sur la tension de déclenchement. Appuyer sur "Single" en haut à droite.

Si tu as un autre oscilloscope c'est le même principe.

J’ai le même mais je n’en ai pas encore la pleine maitrise.

Merci pour l’astuce

Chaque fois que je peux je procède avec une synchro extérieure :

define synchro “numéro de la broche utilisée pour le top de synchro”


digitalWrite(synchro, HIGH);
digitalWrite(synchro, LOW);
// action à tester à l’oscilloscope

Compte tenu de la “vitesse” d’exécution de digitalWrite, un digitalWrite HIGH immédiatement suivi d’un LOW génère un créneau parfaitement détectable par l’entrée synchronisation extérieure de l’oscilloscope.
L’avantage est d’avoir un signal propre pour obtenir une synchronisation parfaitement stable et de libérer une entrée.

Si de plus vous possédez un oscilloscope avec une double base temps vous pourrez utiliser l’effet zoom sur l’ensemble du signal acquis par la base de temps principale.

Salut , du coup , dans ce fil , ona bien 2 problemes distincts dont tu parles Henry ?

le premier du a la comutation de la charge en 230 V et le 2eme du a priori a un probleme de cable ou de longueur de cable .

Du coup quel serait la meilleure option pour eviter les problemes de comutation en 230 V , la varisatnce ?

quel modele de varisatnce ou de condo + resistance chauffera le moins dans le coffret ferme ? je ne voudrais pas que ca prenne feu ...

le premier du a la comutation de la charge en 230 V et le 2eme du a priori a un probleme de cable ou de longueur de cable .

Plus le câble est long plus il est résistif, donc a tendance à atténuer les parasites.

Aucune des deux solutions ne chauffe.

hbachetti: S10K275 marche aussi.

Oui, et on ne met pas les doigts dessus pour voir si ça chauffe :-[

je disais que je ne voulais pas que ca prenne feu a cause de ce post .

sur mes relais , je n ' ai pas de neutre , uniquement la phase qui arrive et repart ( ou pas ) .

un condo " X2 " , kezako ?

je disais que je ne voulais pas que ca prenne feu a cause de ce post .

Simple plaisanterie. Le secteur est présent sur la résistance.

sur mes relais , je n ' ai pas de neutre , uniquement la phase qui arrive et repart ( ou pas ) .

On peut mettre le circuit RC ou la varistance sur la charge (la bobine du contacteur).

Mais le parasite peut provenir aussi de la charge commutée par le contacteur. Il faut faire des essais avec le contacteur seul, ensuite avec contacteur + charge. Je sais que ce ne sont pas des problèmes simples à résoudre. Il faut opérer par essais successifs, c'est "un peu" empirique, à moins d'avoir un oscilloscope pour piéger la surtension qui se produit probablement sur l'alimentation de l'ARDUINO.

un condo " X2 " , kezako ?

Condensateur de sécurité classe X2.