chiarimenti su funzionamento relè

ciao! mi sono cimentato per la prima volta a costruire un circuito con un relè (la mia intenzione è quella di inserirmi alla presa di casa da 220V per poter controllare una lampada). Ho comprato un relè con resistenza interna di 68 ohm, possibilità di carico fino a 220-230V, 5A e con la bobina che viene eccitata a 6V e consuma 100 mA. Ho seguito poi questa guida per essere sicuro di non fare danni http://www.logicaprogrammabile.it/come-pilotare-rele/ Dopo aver effettuato un paio di calcoli per adattare la guida alla mia situazione, ho costruito il circuito, che però non funziona. Infine accidentalmente (effettuando una misurazione sbagliata) ho scoperto che togliendo le resistenze il circuito funziona!!! anche se non capisco perché... =( qualcuno sa spiegarmi perché funziona quando "sulla carta" non dovrebbe? anche perché ho provato a misurare la corrente in uscita dal pin dell'arduino, e il tester mi da 70 mA, ma, correggetemi se sbaglio, l'arduino UNO dà al massimo 40 mA in uscita da un pin...

Il relè come lo alimenti? Puoi postare lo schema che hai fatto?

pighixxx:
Il relè come lo alimenti?
Puoi postare lo schema che hai fatto?

il relè è collegato al pin da 5V dell’Arduino… come anche l’alimentazione da 3,3 V del led…

Manca la resistenza sulla base del transistor.
Perchè usi i 3.3V per il Led?

Qui ci sono un po’ di connessioni base, alla scheda 3 come collegare un relè.

pighixxx:
Manca la resistenza sulla base del transistor.
Perchè usi i 3.3V per il Led?

è proprio quello il “problema”… se inserisco la resistenza non funziona più il circuito… non capisco, funziona, ma non so il perché! :slight_smile:

il led l’ho collegato al 3,3V per comodità, non c’è un motivo specifico… mi serviva un circuito di prova prima di collegarmi alla 220

edoardo89: è proprio quello il "problema".. se inserisco la resistenza non funziona più il circuito.. non capisco, funziona, ma non so il perché! :)

Che resistenza hai messo?

edoardo89: il led l'ho collegato al 3,3V per comodità, non c'è un motivo specifico.. mi serviva un circuito di prova prima di collegarmi alla 220

Con quella resistenza (1K?) puoi collegarlo anche ai 5V.

pighixxx: Che resistenza hai messo?

inizialmente avevo messo una da 3Kohm più un'altra da 10Kohm che scaricava a terra (come nella guida che ho linkato all'inizio).. la seconda non so bene a cosa serva, mi sono fidato della guida

edoardo89: Inizialmente avevo messo una da 3Kohm più un'altra da 10Kohm che scaricava a terra (come nella guida che ho linkato all'inizio).. la seconda non so bene a cosa serva, mi sono fidato della guida

Metti solo una resistenza da 3K tra il pin e la base del transistor.

pighixxx: Metti solo una resistenza da 3K tra il pin e la base del transistor.

ho già provato, nel momento in cui inserisco una resistenza tra il pin e la base, il circuito non funziona più.. ho provato anche ad inserire resistenze più piccole e più grandi, il risultato non cambia.. la cosa strana è che funziona anche se non dovrebbe.. ho anche provato a misurare le correnti di base e di collettore.. ib= 77 mA e ic=70 mA... che è assurdo! eppure funziona

A questo punto mi arrendo :D Mi sembra stranissima la cosa, attendiamo il parere di qualcuno più esperto.

PS) Per caso hai un'altro transistor con cui provare?

ahah :) intendi un altro dello stesso tipo? adesso provo.. dici che potrebbe essere danneggiato quello che sto usando?

pighixxx: Mi sembra stranissima la cosa, attendiamo il parere di qualcuno più esperto.

Che non sono io :grin: , però leggendo il primo post di @edo, sta usando un relè che può pilotare 220V con una corrente continua a 3,3V. @pighi non può essere quello il problema? @edo che caratteristiche ha il relè (datasheet) ?

nid69ita: Che non sono io :grin: , però leggendo il primo post di @edo, sta usando un relè che può pilotare 220V con una corrente continua a 3,3V. @pighi non può essere quello il problema? @edo che caratteristiche ha il relè?

No, ha postato lo schema che sta usano ora ed è "formalmente" corretto a parte la resistenza cha manca

ho provato ad usare un altro bc547b.. stesso risultato.. nel momento in cui inserisco una resistenza in serie, smette di funzionare

edoardo89: ho provato ad usare un altro bc547b.. stesso risultato.. nel momento in cui inserisco una resistenza in serie, smette di funzionare

Curiosità mia. Non è che puoi postare una foto del tutto?

ho "girato" il bjt... :~ ora funziona con la resistenza da 3K in serie tra pin e base... ora le correnti tornano, almeno ho una corrente di base molto bassa e quella di collettore alta! chiedo scusa per questo errore stupido, anche se ancora non capisco come potesse funzionare con collettore ed emettitore invertiti... grazie mille dell'aiuto :D cmq la seconda resistenza, quella collegata a terra, a cosa serve?

edoardo89: cmq la seconda resistenza, quella collegata a terra, a cosa serve?

Serve come riferimento di massa. Serve, in poche parole, per tenere la tensione di base ad un valore basso quando il pin di Arduino è in low per non mandare in conduzione il transistor.

(so che scatenerò le ire dell'inferno per questa spiegazione :D)

pighixxx:
Serve come riferimento di massa.
Serve, in poche parole, per tenere la tensione di base ad un valore basso quando il pin di Arduino è in low per non mandare in conduzione il transistor.

(so che scatenerò le ire dell’inferno per questa spiegazione :D)

ah ok! grazie :smiley:
un’ultima cosa… ora posso procedere con il collegamento alla 220 no? vorrei avere una conferma, visto che sono un novellino e non vorrei combinare danni :slight_smile:
la mia idea adesso era di inserire questo circuito nel filo di una lampada, inserendo il relè (normalmente aperto) sul filo della fase… in questo modo la lampada dovrebbe accendersi quando il segnale del pin è HIGH… giusto?
che precauzioni devo prendere per evitare di bruciare l’arduino o prendere la scossa? :slight_smile:

edoardo89: (cut) che precauzioni devo prendere per evitare di bruciare l'arduino o prendere la scossa? :)

Il buon senso prima di tutto! Se sei un principiante è altamente sconsigliato fare esperimenti con la 220!

BTW se aspetti un attimo ti posto il disegno. Ciao

Tanto buon senso, una buona dose di coraggio, è una valutazione di quello che di peggio può accadere. :) ]:) La casa non deve bruciare, prendi precauzioni, non mettere il circuito sotto la tenda. Tu, se sei lontano dal circuito quando inserisci la spina la scossa di sicuro non puoi prenderla. ;) Coraggio, se fa il botto, tranquillo perchè ti aspetti sempre un botto ci sei abituato e ai preso tutte le precauzione e non c'è di che aver paura quindi con rapidità scolleghi la spina, questo significa che dopo aver collegato la spina non devi avere la necessità di allontanarti. :*

Ciao.