Chipkit Max32 DSPI and Serial fix?

The Chipkit forum is broken (I can’t get the confirmation email for registration) and I haven’t had any luck emailing digilent directly so here I am.

There is a known issue posted all over their forum about how if you enable DSPI and try to read a single byte in Serial the board crashes because of some interrupt pin sharing issue. The issue has been known since at least June of 2011. Here is the latest post I can find about the error:

There are all sorts of hacks people tried without saying what specifically worked for them with regards to their setup (DSPI0, 1, Serial1, 2, etc). I’ve tried doing a few things but have gotten nowhere.

Does anyone out there have a work around for this that I can follow? I would like DSPI0 (default J13 pins) and USB serial to work together. I am not using interrupt driven SPI, btw, just spi.transfer();



The Chipkit forum is broken

So? What does that have to do with Arduino?

hrm. thats weird. I was expecting you to have fewer stars.

This is the "Other Hardware Development" section of the forum. Specifically: "Shields you are designing or that you think would be nice to have, Arduino compatible platforms, board comparisons, etc. "

Chipkit Max32 is an Arduino compatible platform.

Hey, but thanks for helping the conversation move forward.

poodull: The Chipkit forum is broken (I can't get the confirmation email for registration) and I haven't had any luck emailing digilent directly so here I am.


Is this still an issue for you? I'm trying to get it resolved.


Yes! Absolutely! (excitement at someone helping, not anger). Thank you!

I tried another approach siting a few other posts that said if you use DSPI0 (instead of DSPI1) it should work, but that is not true. It took me a while to locate the right pins (anyone have a pin-layout diagram nearly half as good as the Due?) but once I did I received the same error.

It's really quite simple to reproduce. Just use DSPI and I figured I might try switching to regular SPI, but I don't know if that would actually solve anything. Just something to try.

I was also pretty close to giving up and try using my Due. They can't both be messed up.

Oh, and I tried again to log in to Chipkit's forum with no success. My email stating the issue to Digilent has gone unanswered for over a week now.

Thanks again for trying to help.

poodull -

There is no confirmation email for the chipKit forums... when you go to register, it asks you to accept an agreement, then it should have a form with a recapcha.

Please email me - if my email is hidden in my profile, it's my username at gmail. I can't recreate the issue so if you could help me fix it I would appreciate it.

Thanks, Jeremy.

For others out there, it says my account is not yet activated. When I ask to activate it, it does nothing.

While that is an issue, if either you or Jacob have any knowledge on how to make DSPI and Serial work with the Max32, I'd love to hear it.