Chute de tension

Bonsoir,

J'ai un soucis avec un projet :roll_eyes:
J'alimente un survolteur en 12v via un relais commandé en 5v. Le 5v alimente aussi un Arduino pour un autre système.
Lorsque le survolteur est vide (après quelque minute d'arret (condensateur déchargé)) et que je l'alimente, une chute de tension se produit au niveau du 5v et redémarre l'Arduino.
Lorsque le survolteur est chargé (après quelque seconde d'arret (condensateur chargé)) et que je l'alimente, le chute de tension disparait.

Quel serait l'origine du problème et comment y remédier ?
Merci par avance.

Bonjour,
Si l'ensemble du dispositif est alimenté par la même alimentation on peut avoir un appel de courant lors de la commande des relais qui peut engendrer un effondrement de la tension et faire rebooter le microcontrôleur.
Fait un essai avec des alimentations séparées.
Donne nous les caractéristiques de ton alimentation

Bonjour

... et donnes nous des sinfos sur le 'survolteur'.
sa mise en route (charge de condensateur...) sollicite peut être trop fortement l'alimentation 12V actuelle

Tu as raison, le survolteur absorbe beaucoup de courant lors de sa mise sous tension.
J'ai essayé de ne pas passer par le survolteur et ça fonctionne parfaitement.

J'utilise se composant Survolteur

J'ai remarqué que la tension mini du survolteur est de 12v, j'utilise une batterie de ce type la.
C'est peut être un peu léger non ?

Si j'optait pour un survolteur ou la tension d'entré serait entre 5v et 40v https://www.amazon.fr/AZDelivery-Convertisseur-R%C3%A9gulateur-Ajustable-compatible/dp/B08T12J8KL/ref=psdc_2908498031_t1_B086W79QQ8

Tu crois??
Voilà ce qui est indiqué dans les caractéristiques du convertisseur

Courant d'entrée: 15 A maximum (dans des circonstances normales, veuillez fournir un courant de 12 A)

et dans les caractéristiques de la batterie

Courant de sortie: 1-2A

Je pense qu'il y a une erreur de casting.
En plus ce truc est pas terriblement bien conçu. Il est supposé accepter une tension d'entrée entre 10 et 60V alors que le condensateur d'entrée de 1000µF est donné pour 63V.
Avec 1000µF directement sur l'entrée (ou quasiment, difficile à dire avec les photos) on peu s'attendre à un courant d'appel important.
On ne sait pas ce que tu veux faire avec ce convertisseur mais ce truc est prévu pour de la puissance. Et ta configuration semble sous-dimensionnée.

Il semblerait que j'ai mal choisi la batterie !

Mon but est via le survolteur, alimenter des séries d'allumeurs pyrotechnique.
Il faut compter 2ohm par allumeur et environ 0.60A pour son déclenchement en 3ms.
Avec une batterie de 1A, j'augmente la tension à 30v pour être sûr du déclanchement (peut importe la longueur du fil et le nombre d'inflammateurs).
U=(2xNbr d'allumeur+resistance du fil) x 1A
Ex U = (2x6+1.5)x1
U = 13.5v

Les allumeurs sont en série c'est bien ça?

Le raisonnement n'est pas bon.
Si les allumeurs ont 2 Ohms de résistance et que tu montes la tension à 30V
le courant va être de :
30/(2 x 6 + 1,5) = 2,2A
En admettant que le convertisseur ait un rendement de 100% ( ce qui n'est pas le cas) tu aurais coté batterie un courant de :
2,2 x 30 / 12 = 5,5A
Si on prend en compte le rendement qui est donné de l'ordre de 95% si ma mémoire est bonne tu arrives à:
5,5 / 0,95 = 5,8A disons 6A parce que le rendement est peut-être un peu gonflé par le fournisseur.

Bonjour fdufnews
oui , en pyrotechnique les inflammateurs sur une ligne sont en serie, c'est déroutant à priori pour un electronicien qui aurait plutôt vu une commande V en étoile , mais c'est nécessaire dans la mesure où cela permet de tester la continuité des longues ligne avec un faible courant.

J'ai mis un peu de temps à comprendre pourquoi une fois le tir lancé, le 1er infla qui claque temporellement (pas nécessairement le 1er sur l ligne) ne se comporte pas pour les autres infla comme un fusible en coupant la ligne restante, c'est simplement du au temps de réaction et à l'inertie thermique des inflas.

Il faudrait voir le schéma du "survolteur" et/ou mesurer en sortie le temps de montée à Vout
il doit y avoir des bons condos à charger avec l'appel de courant qui va avec , Vin doit surement descendre à des valeurs de brown out qui reset l'arduino.

Oui Artouse c'est exactement ça !

La mise en séries des l'inflamateurs est importante pour le test des lignes. De ce fait, je suis obligé d'augmenter la tension d'allumage.

Le tension Vout m'est du temps pour atteindre la valeur de 30v dû à la charge du condensateur. 1 à 2 s

C'est quoi la valeur de brown out ?

pour faire simple là , c'est la valeur mini de VCC en dessous de laquelle le MCU reset