CNY70 problem

Hello all,

I’m trying to make a line-following robot with 3 CNY70 sensors and one motor controller.

The problem is that I tried to connect the CNY70 like is shown here: but I can’t make it work.

I tried to onli connect the infrared led and measre the V betweeen the resistance and the electricity in the circuit but never have any results…

If anybody could help me, I’ll be happy.

Make sure your CNY70 is working. You might be able to test this by using an IR library and check for signal when aplying power to the LED. Make sure the polarity of the LED is correct. The LED will only work when the polarity (+ & -) are correctly connected.

You wrote you measured no voltage on the LED? Some basic trouble shouting here: Measure the voltage on your powersupply making sure you have the correct output voltage. (if the powersupply is not stabilized it might have a very high voltage that might have coused your LED in the CNY70 to burn out). Measure the voltage across the LED (making sure you connected the voltage to the LED pin)