Code compiling fails 80% of the time

Hello,
Whenever I try to verify or upload any piece of code, about 80% of the time I get this error:

Warning: Board breadboard:avr:atmega328bb doesn't define a 'build.board' preference. Auto-set to: AVR_ATMEGA328BB
WARNING: Category 'General' in library Examples Library is not valid. Setting to 'Uncategorized'
failed MSpanList_Insert 0x3129d8 0x1268dc3bb424 0x0
fatal error: MSpanList_Insert

runtime stack:
runtime.MSpanList_Insert(0x2cadd0, 0x3129d8)
	/usr/local/go/src/runtime/mheap.c:692 +0x8f
runtime.MHeap_Free(0x2cad60, 0x3129d8, 0xc200000000)
	/usr/local/go/src/runtime/mheap.c:500 +0x5b
runtime.MCentral_FreeSpan(0x2d3978, 0x3129d8, 0x5, 0xc2081b0000, 0xc2081b1000, 0x0, 0x64)
	/usr/local/go/src/runtime/mcentral.c:181 +0x1bb
runtime.MSpan_Sweep(0x3129d8, 0x3300000000, 0x1)
	/usr/local/go/src/runtime/mgc0.c:1099 +0x477
runtime.MHeap_Alloc(0x2cad60, 0x3, 0x1000000002c, 0xf989)
	/usr/local/go/src/runtime/mheap.c:240 +0x66
runtime.MCentral_CacheSpan(0x2d4818, 0x311d40)
	/usr/local/go/src/runtime/mcentral.c:85 +0x167
runtime.MCache_Refill(0x30c000, 0x2c, 0x311d40)
	/usr/local/go/src/runtime/mcache.c:90 +0xa0

goroutine 1 [running]:
runtime.switchtoM()
	/usr/local/go/src/runtime/asm_amd64.s:198 fp=0xc208071380 sp=0xc208071378
runtime.mallocgc(0x1200, 0x1a2480, 0xc200000000, 0xc2080b0400)
	/usr/local/go/src/runtime/malloc.go:178 +0x849 fp=0xc208071430 sp=0xc208071380
runtime.newarray(0x1a2480, 0x10, 0x16)
	/usr/local/go/src/runtime/malloc.go:365 +0xc1 fp=0xc208071468 sp=0xc208071430
runtime.hashGrow(0x1b69a0, 0xc20811d110)
	/usr/local/go/src/runtime/hashmap.go:744 +0x86 fp=0xc208071498 sp=0xc208071468
runtime.mapassign1(0x1b69a0, 0xc20811d110, 0xc2080715b0, 0xc2080715a0)
	/usr/local/go/src/runtime/hashmap.go:456 +0x568 fp=0xc208071538 sp=0xc208071498
arduino.cc/properties.Map.Merge(0xc20811d110, 0xc208071660, 0x1, 0x1, 0xc208126400)
	/Users/jenkins/jenkins/workspace/arduino-builder-macosx/src/arduino.cc/properties/properties.go:165 +0x153 fp=0xc208071630 sp=0xc208071538
arduino.cc/properties.Map.Clone(0xc20811d0e0, 0x1f2690)
	/Users/jenkins/jenkins/workspace/arduino-builder-macosx/src/arduino.cc/properties/properties.go:173 +0xad fp=0xc208071688 sp=0xc208071630
arduino.cc/builder.(*RecipeByPrefixSuffixRunner).Run(0xc20801e2e0, 0xc20806a000, 0x0, 0x0)
	/Users/jenkins/jenkins/workspace/arduino-builder-macosx/src/arduino.cc/builder/recipe_runner.go:58 +0x354 fp=0xc208071800 sp=0xc208071688
arduino.cc/builder.runCommands(0xc20806a000, 0xc208071a98, 0x22, 0x22, 0x1, 0x0, 0x0)
	/Users/jenkins/jenkins/workspace/arduino-builder-macosx/src/arduino.cc/builder/builder.go:189 +0x139 fp=0xc208071890 sp=0xc208071800
arduino.cc/builder.(*Builder).Run(0xc208071ce0, 0xc20806a000, 0x0, 0x0)
	/Users/jenkins/jenkins/workspace/arduino-builder-macosx/src/arduino.cc/builder/builder.go:124 +0x1227 fp=0xc208071cc0 sp=0xc208071890
arduino.cc/builder.RunBuilder(0xc20806a000, 0x0, 0x0)
	/Users/jenkins/jenkins/workspace/arduino-builder-macosx/src/arduino.cc/builder/builder.go:220 +0x49 fp=0xc208071ce8 sp=0xc208071cc0
main.main()
	/Users/jenkins/jenkins/workspace/arduino-builder-macosx/src/arduino.cc/arduino-builder/main.go:316 +0x171b fp=0xc208071f98 sp=0xc208071ce8
runtime.main()
	/usr/local/go/src/runtime/proc.go:63 +0xf3 fp=0xc208071fe0 sp=0xc208071f98
runtime.goexit()
	/usr/local/go/src/runtime/asm_amd64.s:2232 +0x1 fp=0xc208071fe8 sp=0xc208071fe0
/Applications/Arduino.app/Contents/Java/arduino-builder returned 2
Error compiling for board Arduino/Genuino Uno.

The other 20% of the time when I try to upload or verify it works successfully.
I tried searching Google but couldn't find the same error. The error still happens no matter what board I compile for. I'm on a Mac running macOS Sierra 10.12.1.
Does anybody know what's happening?

The go-to response for these kinds of errors is: have got the latest IDE from the downloads page?

Warning: Board breadboard:avr:atmega328bb doesn't define a 'build.board' preference.

Usually this means that you have a boards.txt and/or libraries that are incompatible with the version of the arduino IDE that you have installed. (both the format of the files and the locations where they are supposed to be stored have changed over time.) Unless you've made personal changes to things, it is probably easiest to completely remove arduino from your system, reinstall a recent version of the IDE, and then use the "board manager" and "library manager" to re-install the special features ("atmega328bb" isn't an official board type; presumably you've installed it based on some web instructions or installer that is now obsolete...)

Upgrading to the hourly build worked, thanks!

ejj28:
Upgrading to the hourly build worked, thanks!

Livin' life on the edge :slight_smile:

I'm still at IDE 1.6.3

...R

ejj28:

failed MSpanList_Insert 0x3129d8 0x1268dc3bb424 0x0

fatal error: MSpanList_Insert

Just FYI, I believe you encountered this issue:

Which should also be fixed by using Arduino IDE 1.6.12 if you end up having some problems with the hourly build. I'm using the hourly with no problems but it's mostly intended for beta testing only and may not be so stable as the official releases.