Code for Teesny Color Organ. Errors

I have been trying to compile a script for a 8 channel color organ that was in the last Nuts & Volts magazine for a Teensy 3.2. not having much luck making this happen. I have installed Arduino software and Teensyduino and the libraries. This seems to be ok as Arduino sees the Teensyduino and I can send a small program to it. (Blink Fast) The problem is when I run the script for color organ it gives me a error and it’s always the same error regardless what I try. Listed below is the difference steps I have tried to fix this and a link to software the color organ.

What I would like to find out if this is a problem of my making or a software problem.

What I know about software one can put on the head of a pin and have room left over.

C:\arduino-1.6.9\hardware\teensy\avr\libraries\Audio/play_serialflash_raw.h:33:25: fatal error: SerialFlash.h: No such file or directory

#include <SerialFlash.h>

  1. Install Arduino ver 8…errors…uninstalled. Win10
  2. Installed again. error
  3. Install Arduino ver 1.6 error.
  4. Installed Arduino on a difference computer, XP same error.

This link is location of software.


If you need more infor, will be happy to send.

Best Regards


Try removing the include - it may not be needed:

 //#include <SerialFlash.h>


Remove serialflash.h same error

Remove audio.h no longer same error but got a new one. Listed below.


C:\Users\Home\AppData\Local\Temp\build907b7760fa80921712849b52e70106fb.tmp\sketch\libraries\Audio-master\extras\wav2sketch\wav2sketch.c:264:13: error: dereferencing pointer to incomplete type

if (stat(f->d_name, &s) < 0) continue; // skip if unable to stat


C:\Users\Home\AppData\Local\Temp\build907b7760fa80921712849b52e70106fb.tmp\sketch\libraries\Audio-master\extras\wav2sketch\wav2sketch.c:267:15: error: dereferencing pointer to incomplete type

filename = f->d_name;


Using library SD at version 1.0.8 in folder: C:\arduino-1.6.9\hardware\teensy\avr\libraries\SD
Using library SPI at version 1.0 in folder: C:\arduino-1.6.9\hardware\teensy\avr\libraries\SPI
Using library ILI9341_t3 at version 1.0 in folder: C:\arduino-1.6.9\hardware\teensy\avr\libraries\ILI9341_t3
Using library XPT2046_Touchscreen at version 1.2 in folder: C:\arduino-1.6.9\hardware\teensy\avr\libraries\XPT2046_Touchscreen
Using library Adafruit_NeoPixel at version 1.0.4 in folder: C:\arduino-1.6.9\hardware\teensy\avr\libraries\Adafruit_NeoPixel
Using library Wire at version 1.0 in folder: C:\arduino-1.6.9\hardware\teensy\avr\libraries\Wire
Error compiling for board Teensy 3.2 / 3.1.

I didn't think SerialFlash was required because as far as I can see the colour organ doesn't use it, but you can't remove audio.h - that is essential.

If you are compiling the colour organ, how did wav2sketch.c get into it?

I see that the Arduino version you are using is the one that was used by the author of the colour organ code but things might work better if you use the most recent versions. The current Arduino is 1.8.1 and Teensyduino is 1.36 release 2.


I have no idea how the program got into the file, maybe from the audio file.

I did start off with ver 8 but after the problems I had thought maybe using the ver the author used.

Had same error with ver 8.

The original file was made and compiled on a MAC I am using a win10 computer could this be a problem?

I downloaded and installed the colour organ zip file and it compiles for me with no complaints at all.
You must have installed it incorrectly or haven't got the correct settings in the IDE.
P.S. I'm using Win10.

Posted on Paul Stoffregen the problem on his web page and below is his reply.

If older than Teensyduino 1.35, get the latest from the website and install. If you have an old version of Arduino (pay attention to the list of supported versions when you start the installer), you'll need to get the Arduino installer from also. Update Arduino first, then install the new Teensyduino.

When you run the Teensyduino installer, leave all the libs selected. If you don't install SerialFlash, then SerialFlash.h will be missing!

I left all the libs selected and that fix the problem. The 1st instructions said only to install 4. Program ok.