Collegamento display all'header.

Premetto che sono alle primissime armi, ma sono un appassionato di elettronica e confido nel vostro aiuto. Ho provato a cercare su internet una risposta, ma non sono riuscito. Ho acquistato un display http://www.ethermania.com/shop/index.php?main_page=product_info&cPath=91_112&products_id=537, ma è privo dell'header che credo sia quello che qualcuno chiama "fila contatti 40 divisibili stagnati" http://www.ethermania.com/shop/index.php?main_page=product_info&cPath=91_123&products_id=625, chiaramente ne userei solo i 16 necessari. Se quello che ho detto fin'ora è giusto devo assemblarli, cosa per me abbastanza complicata vista la vicinanza dei contatti e la mia poca dimestichezza, ma a parte questo, il display ha contatti su entrambi i lati, devo saldare su tutte e due i lati o basta quello inferiore? Mi dareste qualche consiglio in modo da evitare di buttare tutto?

Inoltre sul lato destro del display ci sono altri 4 contatti con i simboli del + e -, che immagino siano l'alimentazione, ma seguendo alcuni tutorial sul interfacciamento con arduino sembra che non vengono utilizzati, come mai?

Grazie Angelo

Ciao angeloalfa

Io vedo solo una striscia per i contatti. I contatti + e - a lato del diplay sono riportati sugli altri contatti e sono per la retroilluminazione. Serve una resistenza.

http://www.ethermania.com/shop/download/162C_LCD.pdf

Ciao Uwe

Allora provo ad allegare le foto del mio display lcd, sia della parte anteriore http://www.flickr.com/photos/13322181@N07/5505689831/ che di quella posteriore http://www.flickr.com/photos/13322181@N07/5505689739/.

A me sembrano due file di contatti separati... :cold_sweat:

Help me Angelo

anchio sto maneggiando un display come il tuo in questi giorni....nel mio ci sono 16 pin da un lato e altri 16 pin dall'altro lato....è proprio necessaria la saldatura a stagno???? perchè provando un 'hello world' non appare niente sul display, è dovuto al fatto che la strip non l'ho saldata e non fanno contatto tutti i pin? però il display si accende e il contrasto lo riesco a variare....

ciao angeloalfa

Non sono 2 volte 16 contatti ma sono solo 16 contatti che sono su entramb i lati e se guardi bene o usi un multimetro vedrai che nel buco sono collegeti tra di loro. Su uno dei lati vedi anche la cifre 1 e 16. I pin 15 e 16 sono collegati col + e il - di lato per la retroilluminazione. Devi mettere una resistenza per alimentare quelli LED. Tutto chiaro allora. Devi saldare dei pin o un cavetto per collegarlo ad Arduino.

@cavde Sí devi saldare. Deve esserci un contatto sicuro e affidabile di tutti i pin senó avrai sempre problemi.

Ciao Uwe

Senza dubbio devi saldare! Assolutamente senza dubbio!

Ma federico, quanto, ma quanto siccuro sei? ;) ;) ;) Ciao Uwe

Grazie ragazzi, proverò a fare queste saldature senza far danni. Ciao ala prossima

uwefed: Ma federico, quanto, ma quanto siccuro sei? ;) ;) ;) Ciao Uwe

Senza dubbi ^^ Mi piaceva insistere su questo concetto base ^^