Collegare shield relè 12v

salve a tutti,
nelle ultime settimane mi sonno avvicinato ad Arduino, ho fatto vari test pratici relativamente semplice e ora mi sono imbarcato in un progetto un più complesso da utilizzare nel lavoro. In pratica devo utilizzare un arduino uno per pilotare quattro relè che faranno accendere e spegnere dei motori a 220 volt. Lo so, niente di cosi complesso in realtà ma mi sono bloccato nella progettazione hardware:i relè della shield che ho comperato hanno le bobine che funzionano a 12 volt, quindi devo alimentarli esternamente. Il problema sta proprio qui: non mi è chiaro come collegare l’alimentatore esterno da 12v alla shield e come collegare Arduino alla shield. Ho visto altre discussioni in merito nel forum, ma sarà che sono io troppo beginner o che la mia shield è diversa da quelle delle discussione, sta di fatto che non ho le idee chiarissime. Ho paura di fare un bel falò del mio caro Arduino, magari cappellando un collegamento.
Questo è il link della shield: https://www.elcoteam.com/privati/shield-per-arduino-con-4-rele-elettromeccanici-bobina-12v.html
In più allego anche una foto delle entrate nel dettaglio e ringrazio fin da ora chi avrà la pazienza di darmi una mano.

cosi’.

board_4rele_12v.jpg

Grazie mille, stasera provo. Uuna domamda: da quello che ho capito anche se le bobine fossero a 5v dobrei cmq alimentarle separatamente per un problema di amperaggio di arduino no?

Si, è l’“alimentatore esterno” che vedi nello schema…

Una cosa non mi quadra di quel modulo. Ok, le bobine sono a 12V, ma il ponticello Vcc-JVcc, se chiuso, porterebbe i 12V anche sulla parte di comando, che quindi dovrebbe essere pensata per 12 e non 5V (le resistenze in serie ai LED dovrebbero avere un valore maggiore). Mandando solo 5V al terminale Vcc, riusciranno ad accendersi gli optoisolatori?

Claudio_FF:
Mandando solo 5V al terminale Vcc, riusciranno ad accendersi gli optoisolatori?

Quei moduli lavorano in logica inversa, quindi gli opto si accendono portando LOW i pin rispetto a Vcc.

Si, ma la domanda è: Visto che c'è il ponticello per portare opzionalmente i 12V su Vcc, con soli 5V su Vcc si accendono gli opto quando gli ingressi vengono portati a massa?

Inoltre, sempre a causa di quel ponticello, se colleghiamo i 12V a Vcc tramite esso, non portiamo a 12V anche gli ingressi quando non collegati a massa?

infatti il ponticello va levato!

nel caso usassi i 5V potresti lasciarlo.... con tutti i disturbi relativi che ne conseguono

e si, gli opto si accendono con i 5V

Patrick_M:
nel caso usassi i 5V potresti lasciarlo… con tutti i disturbi relativi che ne conseguono
e si, gli opto si accendono con i 5V

Sono relé con bobina 12V, quindi il ponticello chiuso con 5Vcc non va bene perché i relé non si attiverebbero.

Claudio_FF:
Sono relé con bobina 12V, quindi il ponticello chiuso con 5Vcc non va bene perché i relé non si attiverebbero.

si, si questi sono a 12V intendevo come nella versione a 5V che se lasci il ponticello ti porti dietro i disturbi dell'alimentazione in comune... :smiley: