COM on UNO Not Recognizing Anymore

Hi. I hava an uno board that used to connect to my serial port just fine, but recently it hasn’t. The error message says that the port is in use by other programs, or that I need to select another serial port because it can’t find COM3. When I try to select a new serial port, the serial port menu is grayed out. I tried to restart the Arduino program and the board, but it still didn’t work. My last attempt was restarting my whole compuer, and then the serial port worked for about a minute and went back in to the error messages I described. I am usind Arduino 1.0.6. Is there any known solution to a more permanent fix?

Here is the error message.

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.

Arduino: 1.0.6 (Windows NT (unknown)), Board: “Arduino Uno”
processing.app.SerialException: Serial port ‘COM3’ already in use. Try quiting any programs that may be using it.

at processing.app.Serial.(Serial.java:171)

at processing.app.Serial.(Serial.java:92)

at processing.app.SerialMonitor.openSerialPort(SerialMonitor.java:207)

at processing.app.Editor.handleSerial(Editor.java:2483)

at processing.app.Editor$17.actionPerformed(Editor.java:667)

at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)

at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)

at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)

at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)

at javax.swing.AbstractButton.doClick(AbstractButton.java:357)

at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)

at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)

at java.awt.Component.processMouseEvent(Component.java:6263)

at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)

at java.awt.Component.processEvent(Component.java:6028)

at java.awt.Container.processEvent(Container.java:2041)

at java.awt.Component.dispatchEventImpl(Component.java:4630)

at java.awt.Container.dispatchEventImpl(Container.java:2099)

at java.awt.Component.dispatchEvent(Component.java:4460)

at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)

at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)

at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)

at java.awt.Container.dispatchEventImpl(Container.java:2085)

at java.awt.Component.dispatchEvent(Component.java:4460)

at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)

at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)

at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)

at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Have you already tried IDE 1.6.1 ? It contains some improvements with serial devices

I am using IR remotes, and they weren't compatible with 1.6.0, so I downloaded 1.0.6 (I got that version because it was still supported) . Does the new version have IR compatibility?

If you're talking about clashes between Robot library and IRRemote library, it has been fixed with 1.6.1. See blog post http://blog.arduino.cc/2015/03/10/arduino-ide-1-6-1-released/

Yep. Its there. Thanks for your advice. It was very helpful.