COM POrt bei USB Hub nicht gefunden

Hi,

ich bin noch Anfänger und hatte gelesen, wenn ich den Arduino am USB Hub mit externer Stromversorgung nutze, dass ich mir den Computer nicht verschrotten kann.

Habe mir heute mal ein Ampel Sketch gebaut. Wenn ich den Arduino direkt am Computer anschließe, kann ich alles hochladen und es funktioniert.

Jetzt schließe ich den Arduino am USB mit externer Stromversorgung an. Meine Ampelschaltung fängt an zu laufen.

Bis hier hin alles super. Jetzt will ich an dieser Stelle einen neuen Sketch hochladen und bekomme die Meldung:

Arduino: 1.8.10 (Windows 10), Board: “Arduino/Genuino Uno”
Beim Hochladen des Sketches ist ein Fehler aufgetreten
avrdude: ser_open(): can’t open device “\.\COM6”: Das System kann die angegebene Datei nicht finden.

Unter Werkzeuge → Port wird mir nichts angezeigt. Er findet hier quasi keinen Port mehr. Schließe ich es direkt wieder am Computer an, funktioniert alles einwandfrei.

Auffallend ist nur, wenn der Arduino am HUB Angeschlossen ist und die Schaltung läuft, dass die LED nicht ganz so hell sind, so als ob hier weniger Spannung reinkommt.

Hat jemand eine Idee, wie ich den Arduino vollständig am externen USB Hub zum laufen bekomme?

philipp82h:
.....
Hat jemand eine Idee, wie ich den Arduino vollständig am externen USB Hub zum laufen bekomme?

Ja, den Hub miteinem zusätzlichen Netzgerät versorgen.
Es kommt schon mal vor, dass des Hub ohne Netzgerät nicht genügend Spannung liefert.
Einfach mal die Spannung messen.

Meine Arduinos laufen an Hubs.

Meine Glaskugel sagt:
Also ist dein Hub oder dessen Netzteil kaputt.
ohne jede Gewähr

(deleted)

Hallo,

ich habe dieses HUB gekauft gehabt:

https://www.amazon.de/gp/product/B07S2RVRRW/

da es einen ordentlichen Dindruck machte.

Könnte es ggf. helfen wenn ich statt ein 5V Netzteil z.B: einfach ein 7V Netzteil ranhänge?

Das ist der Nachteil, wenn man zwar 20 Jahre Programmiererfahrung hat, aber von Elektronik so viel versteht wie ein Huhn :wink: Ich hoffe es natürlich zu ändern.

Könnte es ggf. helfen wenn ich statt ein 5V Netzteil z.B: einfach ein 7V Netzteil ranhänge?

Falls du auf Rauch und Explosionen stehst, dann ja, sonst eher nicht.

philipp82h:
Könnte es ggf. helfen wenn ich statt ein 5V Netzteil z.B: einfach ein 7V Netzteil ranhänge?

Hast du denn mal die Spannung gemessen, was am Arduino ankommt ?

Ohne eine Messung kann man keine Aussage treffen.

Jedoch sind 7Volt deutlich zu viel.

In den Amazon Daten steht Folgendes:

Unabhängige Ein / Aus-Schalter : Jeder USB 3.0-Port verfügt über einen Ein / Aus-Schalter mit LED-Anzeige, um den Stromstatus anzuzeigen. Wenn die Stromversorgung wiederhergestellt ist, behalten die Ports den zuvor eingestellten Status. USB Verteiler mit Einzelne Ein / Aus Schalter: Ein / Aus Schalter für jeden 7 USB 3.0 Port, keine Treiber erforderlich, mit LED-Anzeige für den Betriebsstatus. Und die blaue LED-Anzeige flackert, wenn Daten übertragen werden.

Mich würden diese Schalter nervös machen. Ansonsten mag 5V/2A für einen Hub etwas knapp sein (abhängig von Portzahl).

Fängt ja schon damit an, dass ich gar nicht wüsste, wo ich in diesem Falle die Spannung messen müsset.

Hat jemand vielleicht ein Link zu einen Hub mit externer Stromversorgung, mit welchen es auf jeden Fall funktioniert?

philipp82h:
Fängt ja schon damit an, dass ich gar nicht wüsste, wo ich in diesem Falle die Spannung messen müsset.

Hat jemand vielleicht ein Link zu einen Hub mit externer Stromversorgung, mit welchen es auf jeden Fall funktioniert?

Och....vielleicht am Arduino, die 5V messen ?

Weiß jetzt nicht, wo ich messen musste. Habe jetzt einfach mal den Scatch laufen lassen, einmal am Rechner USB angeschlossen und einmal am HUB angeschlossen und dann die Spannung auf einem Kippschalter (mitte und außen) gemessen.

Dort hatte ich in beiden Fällen jeweils 4.59 - 4,65 (immer schwankend).

Also auch wenn ich ggf. falsche Stelle gemessen habe sollte, hier war die Spannung gleich.

Weiß jetzt nicht, wo ich messen musste.

Ein jeder(?) Arduino hat GND und 5V Pins.

Dazwischen messen!

Dort hatte ich in beiden Fällen jeweils 4.59 - 4,65 (immer schwankend).

Das ist für einen Anschluss an USB vollkommen ok.