Com port change with Nano 33 BLE Sense

I know that this is not a new issue but the solutions in the FAQs and the forum don’t work and they are all quite elementary and dismissive. I am using a Nano Sense. My sketches compile but after the compile is complete the port gets changed which, of course, causes that upload to fail. I have tried all of the provided solutions but the momentary port disconnection cause the wrong port to be selected. Does anyone have a real solution? Thanks

I’m not familiar with the Nano Sense. If it has native USB (and I think it does), it’s normal that the COM port changes. That is the boot loader starting.

If the board has a reset button, have you tried tapping or double tapping the reset button when the upload starts?

For others to help you, can you please enable verbose output during upload and disable verbose output during compilation in the IDE under file-> preferences and post the full result here after a failed upload.

Some of the newer NANO’s have as sterretje explained what amounts to TWO ports.

There is the standard one you see when you first power up or connect the board.
Then there is a second one often referred to as the BOOTLOADER port.

Arduinos IDE offerings will, during upload swap to that second port as part of the upload procedure.
When upload is complete they normally revert the port back to the first one.

There can be occasions (OS dependant) where ports are not always released properly back to the original one.
Maybe a little more detail of your operating environment would be useful ?

Could you also review How to get the best out of this forum as it will help you find your way around.

I have windows 10 and IDE 1.8.2. I have tried newer and older versions of the IDE with the same result (even 2.0 beta). I also am familiar with the bootloader double tap trick but each time after a successful compile, I get a load error when the designated port cannot be found. Verbose load is enabled but doesn’t provide much additional information. I know that the nano sense is a new construct but it seems that somewhere in the FAQs or instructions for use that this the very basic process of uploading a sketch would be explained. The only information I can find is that the port change is well known but little information as to exactly how to overcome this barrier.

The port change is not a barrier, it’s expected behaviour.

I’ve moved your topic to de dedicated section for the BLE Sense; hopefully somebody there might have an idea.

Thanks for moving my issue. This expected behavior never allows the upload to complete. I sure I’m doing something wrong.

Interesting. I do not see this behaviour.

I am using a nano BLE (not the sense) with windows 10, IDE 1.8.13 and core mbed_nano\2.0.0 which came from the boards manager.

My Nano33 IOT exhibits the change of COM port behaviour which often seems to confuse Windows and leaves the COM port unavailable for the sketch

Yes, that is exactly what appears to happen. If I power cycle the nano device recognizes the correct port but it switches as soon as the upload starts.

Yes, that is exactly what appears to happen. If i power cycle the nano, windows device manager recognizes the correct port which switches as soon as the upload starts. Upload fails because it can't find the nano on the port that it switched to.