COM Port Connectivity

Hey folks,

I'm having an issue with uploading sketches to my Arduino Uno. In the IDE, it sees that the Arduino is plugged into COM4, and the same shows up in Device Manager (I'm running XP). The Arduino is lit up nice and green. Yet when I try to upload, I get:

avrdude: ser_open(): can't open device "\.\COM4": The system cannot find the file specified.

I've tried going into Device Manager and changing the COM port number assigned to the Arduino, which changes the port number in the IDE, but I always get the same error no matter which one I choose.

This has been happening for weeks now, and I used to be able to fix it by some arcane combination of unplugging and resetting the board. But now, none of this seems to work - I'm totally locked out of the Arduino!

I've been combing through Google searches of my error and it hasn't helped. Any help would be much appreciated.

Same thing happened to me but for some reason when I unplugged my arduino and connected jumper cables from the RESET on the Arduino to the GND and then from Pin 1 to Pin two. Make sure your arduino is unplugged while you do this. Then plug it back in and upload an empty sketch. Then it should work fine.

I tried this once with digital pins 1 and 2 and again with analog, with no success :frowning:

Visual Studio 2013 Community edition (free) has debugging built in. Why don't you try?
I could not locate the com port in Device Manager and I attributed it to not having the correct driver.
Details are in couple of my posts on my blogs.