Com port disappeared after resetting board

I am using Windows 10 and my aduino uno doesnt show up on the Com port. It was working initially and I tried to reset it to make an edit to code and it blanked out of the port. I can still see it receiving power from my laptop but not connecting. I tried verbose upload and this is the error I get.

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM10 Using Programmer : arduino Overriding Baud Rate : 115200 An error occurred while uploading the sketch avrdude: ser_open(): can't open device "\.\COM10": The system cannot find the file specified.

avrdude done. Thank you.

my feather m0 had a similar issue but was fixed when I ran the following steps:

"Turn on verbose upload in the Arduino IDE preferences Plug in feather 32u4/M0, it won't show up as a COM/serial port that's ok Open up the Blink example (Examples->Basics->Blink) Select the correct board in the Tools menu, e.g. Feather 32u4 or Feather M0 (check your board to make sure you have the right one selected!) Compile it (make sure that works) Click Upload to attempt to upload the code The IDE will print out a bunch of COM Ports as it tries to upload. During this time, double-click the reset button, you'll see the red pulsing LED that tells you its now in bootloading mode The Feather will show up as the Bootloader COM/Serial port The IDE should see the bootloader COM/Serial port and upload properly"

but it did not work in the case of my uno.

Other thread removed.

Post screenshot of Device Manager and, if present, detailed information of any unknown device, mainly Device's Hardware ID