Com port greyed out with node mcu ESP8266 (solved)

I've been looking for awhile now but couldn't quite find the answer: I have a node mcu ESP8266 board if Iv'e read it correctly I have to flash it firmware my problem is the com port is not able to be selected it's greyed out I have an FTDI board for my pro mini's so it seems I may be able to cobble that together to get the board flashed but how do I get the port to be seen? I've tried to different cable to be sure that was not the problem and I do get power up on the board the blue led is blinking also my board appears a bit different than most mine has oh around 24 pins on it verses the one I've seen with like 8 don't know if thats a problem any takers?

HiLetgo New Version ESP8266 NodeMCU LUA CP2102 ESP-12E Internet WIFI Development Board Open source Serial Wireless Module Works Great with Arduino IDE/Micropython

You need to install the driver for the CP2102 USB-serial chip:

Excellent will give it a go in the morning, thank you!

Ok so I have com port active but not sure how to proceed I took a screen shot of its current issue it seems to be acknowledged but I have tried to do the firmware update and it states the following:

Chugging along I have the com port fix and the firmware loader installed not sure which file I need to upload looks like there are many, does anybody know the file extension I should be looking for or a direct link?

Self help applied I found that you must hold the flash button on the board when upload commences then release and it works! At least the blink sketch works I tried with the standard 1000ms delay and changed it to 100ms to be sure!

Added a karma for not giving up and reporting back.

sterretje: Added a karma for not giving up and reporting back.

Thank you and I will also add to assist others that the node mcu clearly states on the back of the board that it is 9600 baud which caused me to go fight that for a few hours but to upload you must set it to the highest setting something like 920000 and it will upload almost without issue anything lower it it tends to hang then abort, I found literature that indicated 115200 and it worked on occasion but the higher setting and its much more consistent with uploads.