COM port no longer available when using SD card shield

Edit: Disconnected 5V and ground from breadboard and port is available again, seems like it's a problem with my wiring after all, no need to continue reading.

I've been using a Mega with an SD card shield for a while and everything worked. I have a lot of wires entangled, so today I cleaned those up, twisted some up and bundled them together with zip ties. Now when I tried to connect to my arduino, there is no port available. I tried a bunch of things, but nothing is working, here is an overview:

  • I can connect to the Mega (and a Uno) without the shield (so no cable issue)
  • I can't connect to a Uno with the shield (seems to be a shield issue)
  • The usual leds (1 on shield and 1 on mega) are on.
  • Led L on Mega lights up weakly when shield is on Mega/Uno (null sketch uploaded without shield connected)
  • When I used my battery in combination with the usb cable (when I was considering a bad connection from the cable, which happened before), I was able to upload the Cardinfo sketch. The battery stopped working after about half a minute though. But when I connected the battery to my Uno board, it was working again.
  • These are the pins I use:
  • 5V and ground to breadbord
  • A2 and A3 for sensors
  • D2 to D9 for sensors
  • D10 to D13 for SPI bus (wired to 50 to 53 on Mega)
  • D20 and D21 for I2C

I'm going over all my wires trying to find a wrong connection, but I have no idea if that's the cause.
Is something broken ?
Any insight/advice is appreciated.