COM Port Problem, Windows 10

OS: Windows 10 PRO / Arduino Uno

I've been operational with this microcontroller for months; yet, after upgrading to version 1.6.12, USB communication is blocked.

IDE main window shows:

Tools / Board

Tools / Port is "greyed out'

displays on bottom right of screen

<avrdude: ser_open(): can't open device "\.\COM3> is flagged upload error in IDE

Windows Device Manager / USB controllers / <Unknown USB Device (Device Descriptor Request Failed>

I've scoured posts in this Forum and tried many, many 'fixes' with no success. The software seems to recognize the port but Windows doesn't. As well, I've tried uninstall/install with several legacy versions and again to 1.6.12 with no change.

Any ideas would be greatly appreciated.

1.6.12 does not make any changes to the drivers - and this is a driver problem. So the IDE version is a red herring.

It sounds like there's something wrong with your board. Test it on another system to confirm - and/or test another board with your computer.

With the IDE version out of play, I did install the software on an old laptop, plugged in the Arduino and the board along with a configured COM port showed. All was well ...

So now my main workstation with Arduino software uninstalled and USB connection removed, accepted a re-install and recognized the driver for the COM port (showed in Device Manager). Some firmware and library updates were suggested and installed.

All is now well (again) .... nice .... If I need to (ever) reinstall, I'll be sure to remove all hardware traces of the microcontroller too. Thanks for your help