COM ports greyed out on Ubuntu

I installed Arduino on the newest version of Ubuntu by using sudo apt-get install arduino. I don't know anything about linux and the serial ports are greyed out in the IDE. I tried using sudo arduino to start it, but that didn't fix it.

I do not recommend using the repository version. It is too old.

Go to the download section of this website and get the newest IDE (V1.6.9). Download and unpack it. Navigate to the directory where it was unpacked and run the arduino shell script there.

Which version of Ubuntu are you using? V16.04? If the Arduino is plugged into the usb port, and the "/dev/ttyACM0" port is showing but greyed out, you may have a group access challenge. Normally it is because your user is not a member of the dialout or uucp groups.

I installed the version from the site like you said. I'm a member of the dialout group, and I've tried running it as sudo. It's not showing any serial ports, the serial port item on the menu is completely greyed out