come digitalizzare con questi livelli di tensione

ciao
aggiorno il lavoro con lo schema e con il circuito simulato il LT, i risultati mi sembrano accetabili, ma vorrei porre una domanda, (in LT non esiste il componente LM358, e le librerie per LT dalla Texas non funziona), cosa bisogna guardare principalmente per comparare gli opamp di due aziende diverse principalmente?

grazie
stefano

XYmodule.asc (1.95 KB)

XYmodule.pdf (10.6 KB)

Ti deludo. Quel circuito non funziona col LM358. La sua uscita non puó arrivare al 3,3V ma si ferma ca 2V sotto. Devi usare per esempio il LMV358. Perché vuoi aliemntarelo con 3,3V? non hai 5V a disposizione? L' entrata digitale ha un impedanza virtuale di ca 10kOhm. Se metti un 100kOhm tra uscita del operazionale e l' entrata analogica non riusirai a caricare nei tempi stabiliti il condensatore di campionamento interno che vien usato per tenere costante la tensione durante la conversione. Non so dirti se il condensatore da 0,1µF puó tamponare e fornire la corrent necessaria.

Ciao Uwe

ciao la mia soddisfazione nasceva dai risultati del simulatore l' opamp utilizzato era uno generico, visto che LT non ha in elenco LM358, però i risultati erano quelli che mi servono, purtroppo non ho la formazione adeguata e quindi a parte il vostro aiuto, devo fidarmi dei risultati che ottengo, sono partito del supporto fornito da Leo e Astrobeed, scusa ma non trovo in elenco LMV358

grazie stefano

in quale elenco? Ciao Uwe

ciao mi riferisco all'elenco dei componenti di LTspice

stefano

???

@uwe ho trovato il modello LMV358 stasera provo a inserirlo e vedo che risultati ottengo dalla simulazione, aggiorno stefano

stefa24: @uwe ho trovato il modello LMV358 stasera provo a inserirlo e vedo che risultati ottengo dalla simulazione,

Prima cosa, gli SPICE mentono, devi conoscere l'elettronica molto meglio di loro per poterli usare in modo corretto e capire se i risultati ottenuti sono attendibili oppure no. Secondo, devi alimentare il LM358 a 5V, e pure questo te lo avevo già detto, se lo alimenti a 3.3V non ottieni il range necessario di tensione.

stefa24: ciao aggiorno il lavoro con lo schema e con il circuito simulato il LT, i risultati mi sembrano accetabili, ma vorrei porre una domanda, (in LT non esiste il componente LM358, e le librerie per LT dalla Texas non funziona), cosa bisogna guardare principalmente per comparare gli opamp di due aziende diverse principalmente?

grazie stefano

Puoi aggiungere i modelli dei componenti di ulteriori op-amp in LTSpice, tramite il componente opamp2 e delle direttive puoi poi richiamarli per fare le simulazioni

Gli op-amp hanno molti parametri importanti, un primo parametro di confronto può essere il prodotto guadagno per larghezza di banda (GBW), lo swing dell'ingresso e dell'uscita (es. se è rail-to-rail), il package, etc..

Ciao

Questo è un esempio di come utilizzare un LM358 in LtSpice:

  • Copia i file allegati in C:\Program Files\LTC\LTspiceIV\lib\sub servono per dire a LTSpice come funziona il LM358
  • Nel circuito aggiungi la direttiva: “.lib LM358.MOD.txt”
  • Imposta il nome dell’opamp2 come “LM358/NS”

dovresti ottenere qualcosa di simile a:

Ciao

LM358.sub (2.04 KB)

LM358.MOD.txt (2.83 KB)

grazie per il supporto
@Astrobeed posto lo schema come indicato,
@ flz47655 non mi riconosce il componente, sicuramente sbaglio qualcosa

XYmodule.pdf (10.6 KB)

flz47655: Questo è un esempio di come utilizzare un LM358 in LtSpice: - Copia i file allegati in C:\Program Files\LTC\LTspiceIV\lib\sub servono per dire a LTSpice come funziona il LM358 - Nel circuito aggiungi la direttiva: ".lib LM358.MOD.txt" - Imposta il nome dell'opamp2 come "LM358/NS"

dovresti ottenere qualcosa di simile a:

Ciao

ciao non vedo l'immagine, ho seguito le istruzioni ma ottengo un messaggio d'errore "xu2 n006 n003 n005 n004 .lib lm358.mod.txt lm358ns" ho anche rinominato i pin di opamp2 in accordo a quello scritto nel file .mod.txt, ma niente non ho capito il perchè di due file per lo stesso componente

grazie stefano

http://imageshack.us/photo/my-images/838/circuitok.png/

In alternativa se trovi difficoltà il programma TINA-TI è gratuito http://www.ti.com/tool/tina-ti ed ha il componente di default

astrobeed:

stefa24: @uwe ho trovato il modello LMV358 stasera provo a inserirlo e vedo che risultati ottengo dalla simulazione,

Prima cosa, gli SPICE mentono, devi conoscere l'elettronica molto meglio di loro per poterli usare in modo corretto e capire se i risultati ottenuti sono attendibili oppure no. Secondo, devi alimentare il LM358 a 5V, e pure questo te lo avevo già detto, se lo alimenti a 3.3V non ottieni il range necessario di tensione.

ciao ho corretto con i 5v per il resto concordo che devi conoscere la materia meglio di loro stessi, ma per hobby se non ci si può fidare un minimo non si può sempre chiedere al forum

grazie stefano

flz47655:
http://imageshack.us/photo/my-images/838/circuitok.png/

In alternativa se trovi difficoltà il programma TINA-TI è gratuito http://www.ti.com/tool/tina-ti ed ha il componente di default

allego il .asc

grazie

XYmodule.asc (1.7 KB)

Devi impostare come “value” dell’op-amp2 “LM358/NS”
Ti allego un esempio di LM358 in configurazione non invertente

Ciao

LM358.asc (1.28 KB)

Ecco il tuo file corretto

XYmodule.asc (1.84 KB)

ciao grazie per il supporto, adesso vedo di passare al modello reale per vedere che succede

stefano

Ecco dalla simulazione quello che si ottiene in uscita all’op-amp (verde) dato il segnale dell’ingresso non invertente (blu)

uscita.png

ciao si esatto è quello che ottengo domani vedo di fare la prove hardware

stefano