communicating 5 arduinos UNO R3 = 1 master and 4 slave. Using max 485 ic.

newbie here. need help, to those master in Arduinos.

anyone can give me an idea which version of Arduino software support #include <ICSC.h>

I’m stuck this type of function because I’m using New version.

After Compiling.

" status 1
error compiling for board Arduino/Genuino Uno."

What about the rest of the error message?

Arduino: 1.8.4 (Windows Store 1.8.8.0) (Windows 10), Board: “Arduino/Genuino Uno”

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\tools-builder -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr -built-in-libraries C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\libraries -libraries C:\Users\alibaba\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10804 -build-path C:\Users\alibaba\AppData\Local\Temp\arduino_build_259821 -warnings=none -build-cache C:\Users\alibaba\AppData\Local\Temp\arduino_cache_294350 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr -verbose C:\Users\alibaba\AppData\Local\Temp\arduino_modified_sketch_734791\sketch_sep18a.ino
C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\arduino-builder -compile -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\tools-builder -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr -built-in-libraries C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\libraries -libraries C:\Users\alibaba\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10804 -build-path C:\Users\alibaba\AppData\Local\Temp\arduino_build_259821 -warnings=none -build-cache C:\Users\alibaba\AppData\Local\Temp\arduino_cache_294350 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr -verbose C:\Users\alibaba\AppData\Local\Temp\arduino_modified_sketch_734791\sketch_sep18a.ino
Using board ‘uno’ from platform in folder: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\arduino\avr
Using core ‘arduino’ from platform in folder: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\arduino\avr
Detecting libraries used…
“C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10804 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\arduino\avr\cores\arduino” “-IC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\arduino\avr\variants\standard” “C:\Users\alibaba\AppData\Local\Temp\arduino_build_259821\sketch\sketch_sep18a.ino.cpp” -o “nul”
“C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10804 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\arduino\avr\cores\arduino” “-IC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.8.0_x86__mdqgnx93n4wtt\hardware\arduino\avr\variants\standard” “C:\Users\alibaba\AppData\Local\Temp\arduino_build_259821\sketch\sketch_sep18a.ino.cpp” -o “C:\Users\alibaba\AppData\Local\Temp\arduino_build_259821\preproc\ctags_target_for_gcc_minus_e.cpp”
C:\Users\alibaba\AppData\Local\Temp\arduino_modified_sketch_734791\sketch_sep18a.ino:2:18: fatal error: ICSC.h: No such file or directory

#include <ICSC.h>

^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

tl;dr

fatal error: ICSC.h: No such file or directory

Where did you put the ICSC library?

I'm using windows 10 then I downloaded 1.8 version of Arduino. I'm only migrating the library to the libraries of the new version.

Thanks, Mr. awol I saw your quotes. I uninstall and Reinstall again the software in migrating my library file to program files C:\ library storage of version 1.8 Arduino. it's working now.