Communication between arduino uno and PC fail

Thanks for everything before starting.

I'm new in arduino and I need to do a proyect (studing) running and controling a DC motor, speed and direction just using channel A or B. To control de direction I use two pushbottons.

Before starting with the proyect, I try to check and do the LEDs examples to get familiar with arduino and simulink, and everything was ok. A week after I started to work with a DC motor using a MOTOR SHIELD and everything was ok. Easy examples to test it.

Now I can't get connection between the arduino uno + motor shiel and the computer. and the error I have is: "the call to realtime_make_rtw_hook during the after_make hook generated the following error: Cuold no connect to specified arduino board" Using the Aduino software the error is: "avrdude.exe:stk500_getsyn( ): not in sync resp=0x00"

I check and reinstall the drivers, set the same port number to arduino software which is identified at the computer, but it doesn't work.

In my arduino there are two leds on, a green one that indicates power on, and yellow, one identify with an L,whch is next to the led of pin13 (I imagine herre is related to reset botton).

What can I do? Any good idea?

Hello xanxes

That error message comes from Simulink, is that right?

If so, have you tried the steps suggested here?

http://www.mathworks.co.uk/help/simulink/ug/troubleshooting_btf8qis.html

And have you tried connecting to the Uno from the Arduino IDE and running a simple example program?

Regards

Ray

Hello Ray,

I check that link before post my problem and still keep on with it, but thanks.

The question is that it doesn't work with simulink and arduino software. The error I get (in each program) is posted above. I try to load an arduino example, which is correct and without programming problems, and nothing. The same with simulink. Just a blink diode.

Thaks again

Regards

Xanxes

it doesn't work with simulink and arduino software

Can you please post the error messages you get from the Arduino IDE when you try to compile and load an example program? You can copy and paste them from the message window at the bottom of the IDE.

Regards

Ray

Using the Aduino software the error is:

"avrdude.exe:stk500_getsyn( ): not in sync resp=0x00"

Thanks and regards