communication probleme arduino uno R3

hi all,

for beginning sorry for my bad english and maybe stupid question.

but im desperate.

in the beginning i got no problems with the conection but now…

i got errors that the com port i use already is in use.

arduino is the only program i run with that com port (6)

i got this error in arduino software.

i'm getting this error to a few times.

i hope i can help others but i think i found the probleme. i connected pin 2 till 13 on special relais to switch 230v.

when i disconnected all the pins everything works fine !!!! :astonished:

i connected pin for pin on the board.

when i connected pin 13 the probleme is there again!!

when you put the voltage on the arduino board the led 13 is automatic blinkin a few times. when i got the relais connected the relais switching a few times to.

i think this will make a connection fault on the usb connection.

so pull the wires on pin 13 off before uploading your sketch!!!

hope i helpt a lot of people with this.

greetings Marcel

Hi Marcel, thank you for telling us your solution.

Actually you can find out what pins will interfere with an upload. It is unlikely to be pin 13. But you can find that out by only connecting pin 13 to your board, if you'd like to hunt for the reason of these troubles. Pins 0 and 1 are used for serial communications. If you are using those with a shield, thjs might get you in trouble when attempting an upload. Also keep in mind that you are limited in the power you consume with your setup, certainly when powering from USB only.

En verder, er is ook een Nederlands deel hier. Maakt het communiceren een stuk gemakkelijker als het in het Engels wat lastig mocht zijn.

hi MAS3,

thanks for your reply. i dont use pin 0 and 1 because that pins are for comunnication. i run the arduino on a seperate 14v 300mA adaptor. and i got another 5v 1A usb adaptor for the main voltage of my relais. i think that that must be enough for this.

if i disconnect pin 13 everything works fine. if i connect the pin 13 again i got that same massage.

that solution is for my enough! :P